Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#1002 closed defect (invalid)

nodes are not linked correctly

Reported by: ittayd@… Owned by: pkropf
Priority: normal Component: GraphvizPlugin
Severity: major Keywords:
Cc: Trac Release: 0.10

Description (last modified by coderanger)

i have the graphviz spec as below:

{{{
#!graphviz
digraph D {
specifications_RequestAsService [label=RequestAsService,URL="/trac/wiki/specifications/RequestAsService"];
specifications_model [label=model,URL="/trac/wiki/specifications/model"];
specifications_RuntimeVsConfiguration [label=RuntimeVsConfiguration,URL="/trac/wiki/specifications/RuntimeVsConfiguration"];
subgraph cluster_specifications_provisioning {
label=provisioning;
URL="/trac/wiki/specifications/provisioning";
specifications_provisioning_CreateRequests [label=CreateRequests,URL="/trac/wiki/specifications/provisioning/CreateRequests"];
specifications_provisioning_ChangeRequests [label=ChangeRequests,URL="/trac/wiki/specifications/provisioning/ChangeRequests"];
specifications_provisioning_OtherFieldValue [label=OtherFieldValue,URL="/trac/wiki/specifications/provisioning/OtherFieldValue"];
}
subgraph cluster_specifications_portal {
label=portal;
URL="specifications/portal";
specifications_portal_Search [label=Search,URL="/trac/wiki/specifications/portal/Search"];
specifications_portal_Help [label=Help,URL="/trac/wiki/specifications/portal/Help"];
specifications_portal_OpenByRequestId [label=OpenByRequestId,URL="/trac/wiki/specifications/portal/OpenByRequestId"];
specifications_portal_ResourcesList [label=ResourcesList,URL="specifications/portal/ResourcesList"];
specifications_portal_OtherFieldValue [label=OtherFieldValue,URL="/trac/wiki/specifications/portal/OtherFieldValue"];
}
specifications_Audit [label=Audit,URL="/trac/wiki/specifications/Audit"];
specifications_provisioning_CreateRequests -> specifications_RequestAsService;
specifications_portal_OtherFieldValue -> specifications_provisioning_OtherFieldValue;
}

}}}

i changed tho plugin, so it logs debug message of the launch method. this is what i get:

2006-12-14 10:30:22,653 Trac[graphviz] DEBUG: launch: cmd="/usr/bin/dot" -Gfontsize=10 -Gfontname="Andale Mono"  -Tsvg -o/tmp/trac/htdocs/graphviz/59b66d6c0
5fb432ed53623f1def6b334484b95cd.dot.png.svg, input=digraph D {
subgraph cluster_specifications_portal {
label=portal;
URL="/trac/wiki/specifications/portal";
specifications_portal_Search [label=Search,URL="/trac/wiki/specifications/portal/Search"]; 
specifications_portal_Help [label=Help,URL="/trac/wiki/specifications/portal/Help"]; 
specifications_portal_OpenByRequestId [label=OpenByRequestId,URL="/trac/wiki/specifications/portal/OpenByRequestId"]; 
specifications_portal_ResourcesList [label=ResourcesList,URL="/trac/wiki/specifications/portal"]; 
specifications_portal_OtherFieldValue [label=OtherFieldValue,URL="/trac/wiki/specifications/portal/OtherFieldValue"]; 
}
subgraph cluster_specifications_provisioning {
label=provisioning;
URL="/trac/wiki/specifications/provisioning";
specifications_provisioning_CreateRequests [label=CreateRequests,URL="/trac/wiki/specifications/provisioning/CreateRequests"]; 
specifications_provisioning_ChangeRequests [label=ChangeRequests,URL="/trac/wiki/specifications/provisioning"]; 
specifications_provisioning_OtherFieldValue [label=OtherFieldValue,URL="/trac/wiki/specifications/provisioning/OtherFieldValue"]; 
}
specifications_RequestAsService [label=RequestAsService,URL="/trac/wiki/specifications/RequestAsService"]; 
specifications_model [label=model,URL="/trac/wiki/specifications/model"]; 
specifications_RuntimeVsConfiguration [label=RuntimeVsConfiguration,URL="/trac/wiki/specifications/RuntimeVsConfiguration"]; 
specifications_Audit [label=Audit,URL="/trac/wiki/specifications/Audit"]; 
specifications_provisioning_CreateRequests -> specifications_RequestAsService;
specifications_portal_OtherFieldValue -> specifications_provisioning_OtherFieldValue;
}

note the ResourcesList and ChangeRequests don't have the right URL

Attachments (0)

Change History (2)

comment:1 Changed 8 years ago by anonymous

  • Resolution set to invalid
  • Status changed from new to closed

further digging revealed this is as a result of doing wiki_to_oneliner on specifications/portal/ResourcesList using [specifications/portal/ResourcesList] doesn't help, but specifications/portal/ResourcesList? does.

so i guess this is not a bug with the plugin

comment:2 Changed 8 years ago by coderanger

  • Description modified (diff)

Making formatting suck less

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from pkropf. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.