Modify

Opened 2 years ago

Closed 2 years ago

#10098 closed defect (duplicate)

GitPlugin TypeError: 'NoneType' object is unsubscriptable

Reported by: james Owned by: hvr
Priority: normal Component: GitPlugin
Severity: normal Keywords: python error
Cc: Trac Release: 0.11

Description

Current setup is Trac 0.11 running on Bitnami trac stack on Windows 64bit. I have git installed and setup to point to c:/Git/bin/git.exe (avoiding the path " " issue). However when leaving enabled I'm getting this error and the warning 'Warning: Error with navigation contributor "BrowserModule"' and "GitPlugin TypeError: 'NoneType' object is unsubscriptable".

Anyone know why? I haven't done anything weird I don't think that would cause this to happen.

How to Reproduce

While doing a GET operation on /report/8, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'id': u'8'}

User agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_4) AppleWebKit/536.5 (KHTML, like Gecko) Chrome/19.0.1084.56 Safari/536.5

System Information

Trac 0.12.3
Babel 0.9.5
Genshi 0.6
GIT 1.7.10.msysgit.1
mod_wsgi 3.3 (WSGIProcessGroup WSGIApplicationGroup %{GLOBAL})
pysqlite 2.6.0
Python 2.6.2 (r262:71605, Apr 14 2009, 22:40:02) [MSC v.1500 32 bit (Intel)]
setuptools 0.6c11
SQLite 3.6.2
Subversion 1.6.15 (r1038135)
jQuery 1.4.4

Enabled Plugins

tracaccountmanager 0.3.2
tracgit 0.11.0.2

Python Traceback

Traceback (most recent call last):
  File "build\bdist.win32\egg\trac\web\main.py", line 522, in _dispatch_request
    dispatcher.dispatch(req)
  File "build\bdist.win32\egg\trac\web\main.py", line 208, in dispatch
    chosen_handler)
  File "build\bdist.win32\egg\trac\web\main.py", line 350, in _pre_process_request
    chosen_handler = filter_.pre_process_request(req, chosen_handler)
  File "build\bdist.win32\egg\trac\versioncontrol\api.py", line 330, in pre_process_request
    repo = self.get_repository(reponame)
  File "build\bdist.win32\egg\trac\versioncontrol\api.py", line 538, in get_repository
    repos = connector.get_repository(rtype, rdir, repoinfo.copy())
  File "build\bdist.win32\egg\tracext\git\git_fs.py", line 162, in get_repository
    shortrev_len=self._shortrev_len)
  File "build\bdist.win32\egg\tracext\git\git_fs.py", line 180, in __init__
    Repository.__init__(self, "git:"+path, None, log)
  File "build\bdist.win32\egg\trac\versioncontrol\api.py", line 744, in __init__
    self.reponame = params['name']
TypeError: 'NoneType' object is unsubscriptable

Attachments (0)

Change History (1)

comment:1 Changed 2 years ago by anonymous

  • Resolution set to duplicate
  • Status changed from new to closed

a duplicate of #8465.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from hvr. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.