Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#10099 closed defect (duplicate)

WindowsError: (5, 'Access is denied')

Reported by: james Owned by: hvr
Priority: normal Component: GitPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

Similar to: http://trac-hacks.org/ticket/9646

Anyone know what is causing this or how to stop it?

How to Reproduce

While doing a GET operation on /browser, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'path': '/'}

User agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_4) AppleWebKit/536.5 (KHTML, like Gecko) Chrome/19.0.1084.56 Safari/536.5

System Information

Trac 0.12.3
Babel 0.9.5
Genshi 0.6
GIT 1.7.10.msysgit.1
mod_wsgi 3.3 (WSGIProcessGroup WSGIApplicationGroup %{GLOBAL})
pysqlite 2.6.0
Python 2.6.2 (r262:71605, Apr 14 2009, 22:40:02) [MSC v.1500 32 bit (Intel)]
setuptools 0.6c11
SQLite 3.6.2
Subversion 1.6.15 (r1038135)
jQuery 1.4.4

Enabled Plugins

tracaccountmanager 0.3.2
tracgit 0.12.0.5dev

Python Traceback

Traceback (most recent call last):
  File "build\bdist.win32\egg\trac\web\main.py", line 522, in _dispatch_request
    dispatcher.dispatch(req)
  File "build\bdist.win32\egg\trac\web\main.py", line 243, in dispatch
    resp = chosen_handler.process_request(req)
  File "build\bdist.win32\egg\trac\versioncontrol\web_ui\browser.py", line 390, in process_request
    dir_data = self._render_dir(req, repos, node, rev, order, desc)
  File "build\bdist.win32\egg\trac\versioncontrol\web_ui\browser.py", line 552, in _render_dir
    entries = [entry(n) for n in node.get_entries()
  File "build\bdist.win32\egg\tracext\git\git_fs.py", line 544, in get_entries
    yield GitNode(self.repos, ent[-1], self.rev, self.log, ent, historian)
  File "C:\Program Files\Trac\python\lib\contextlib.py", line 23, in __exit__
    self.gen.next()
  File "build\bdist.win32\egg\tracext\git\PyGIT.py", line 760, in get_historian
    p[0].terminate()
  File "C:\Program Files\Trac\python\lib\subprocess.py", line 911, in terminate
    TerminateProcess(self._handle, 1)
WindowsError: [Error 5] Access is denied

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by jamesingham

Is there a quick way I can modify build\bdist.win32\egg\tracext\git\PyGIT.py? As this seems to be where the problem is but I cannot find the file!

comment:2 Changed 3 years ago by anonymous

  • Resolution set to duplicate
  • Status changed from new to closed

a duplicate of #9646.

The plugin maybe is installed at C:\Program Files\Trac\python\lib\site-packages\TracGit-0.12.0.5dev*.egg.

comment:3 Changed 3 years ago by james

Where is the file I need to edit for my own version of trac?

Add Comment

Modify Ticket

Action
as closed The owner will remain hvr.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.