Modify

Opened 2 years ago

Closed 2 years ago

Last modified 3 months ago

#10189 closed defect (fixed)

error related with "attachment" command

Reported by: swsm@… Owned by: rjollos
Priority: high Component: SlideShowPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.12

Description (last modified by rjollos)

  • rev 11796
  • ver 0.3

I attached a file "link.zip" and write down like below, but i got a error message from trac.

Here are the content what has problem:

[[SlideShow(theme=i18n)]]
= TItle=
* line1
* attachment:link.zip

error message

Traceback (most recent call last):
  File "C:\Program Files\VisualSVN Server\trac\python\lib\site-packages\trac-0.12.3-py2.6-win32.egg\trac\web\api.py", line 441, in send_error
    data, 'text/html')
  File "C:\Program Files\VisualSVN Server\trac\python\lib\site-packages\trac-0.12.3-py2.6-win32.egg\trac\web\chrome.py", line 870, in render_template
    encoding='utf-8')
  File "C:\Program Files\VisualSVN Server\trac\python\lib\site-packages\genshi-0.6-py2.6.egg\genshi\core.py", line 183, in render
    return encode(generator, method=method, encoding=encoding, out=out)
  File "C:\Program Files\VisualSVN Server\trac\python\lib\site-packages\genshi-0.6-py2.6.egg\genshi\output.py", line 58, in encode
    for chunk in iterator:
  File "C:\Program Files\VisualSVN Server\trac\python\lib\site-packages\genshi-0.6-py2.6.egg\genshi\output.py", line 339, in __call__
    for kind, data, pos in stream:
  File "C:\Program Files\VisualSVN Server\trac\python\lib\site-packages\genshi-0.6-py2.6.egg\genshi\output.py", line 826, in __call__
    for kind, data, pos in stream:
  File "C:\Program Files\VisualSVN Server\trac\python\lib\site-packages\genshi-0.6-py2.6.egg\genshi\output.py", line 670, in __call__
    for kind, data, pos in stream:
  File "C:\Program Files\VisualSVN Server\trac\python\lib\site-packages\genshi-0.6-py2.6.egg\genshi\output.py", line 771, in __call__
    for kind, data, pos in chain(stream, [(None, None, None)]):
  File "C:\Program Files\VisualSVN Server\trac\python\lib\site-packages\genshi-0.6-py2.6.egg\genshi\output.py", line 586, in __call__
    for ev in stream:
  File "C:\Program Files\VisualSVN Server\trac\python\lib\site-packages\genshi-0.6-py2.6.egg\genshi\core.py", line 288, in _ensure
    for event in stream:
  File "C:\Program Files\VisualSVN Server\trac\python\lib\site-packages\genshi-0.6-py2.6.egg\genshi\core.py", line 288, in _ensure
    for event in stream:
  File "C:\Program Files\VisualSVN Server\trac\python\lib\site-packages\trac-0.12.3-py2.6-win32.egg\trac\web\chrome.py", line 984, in _strip_accesskeys
    for kind, data, pos in stream:
  File "C:\Program Files\VisualSVN Server\trac\python\lib\site-packages\genshi-0.6-py2.6.egg\genshi\core.py", line 288, in _ensure
    for event in stream:
  File "C:\Program Files\VisualSVN Server\trac\python\lib\site-packages\trac-0.12.3-py2.6-win32.egg\trac\web\chrome.py", line 973, in _generate
    for kind, data, pos in stream:
  File "C:\Program Files\VisualSVN Server\trac\python\lib\site-packages\genshi-0.6-py2.6.egg\genshi\template\base.py", line 605, in _include
    for event in stream:
  File "C:\Program Files\VisualSVN Server\trac\python\lib\site-packages\genshi-0.6-py2.6.egg\genshi\template\markup.py", line 378, in _match
    ctxt, start=idx + 1, **vars):
  File "C:\Program Files\VisualSVN Server\trac\python\lib\site-packages\genshi-0.6-py2.6.egg\genshi\template\markup.py", line 378, in _match
    ctxt, start=idx + 1, **vars):
  File "C:\Program Files\VisualSVN Server\trac\python\lib\site-packages\genshi-0.6-py2.6.egg\genshi\template\markup.py", line 327, in _match
    for event in stream:
  File "C:\Program Files\VisualSVN Server\trac\python\lib\site-packages\genshi-0.6-py2.6.egg\genshi\template\base.py", line 545, in _flatten
    for kind, data, pos in stream:
  File "C:\Program Files\VisualSVN Server\trac\python\lib\site-packages\genshi-0.6-py2.6.egg\genshi\core.py", line 288, in _ensure
    for event in stream:
  File "C:\Program Files\VisualSVN Server\trac\python\lib\site-packages\genshi-0.6-py2.6.egg\genshi\path.py", line 588, in _generate
    subevent = next()
  File "C:\Program Files\VisualSVN Server\trac\python\lib\site-packages\genshi-0.6-py2.6.egg\genshi\template\base.py", line 605, in _include
    for event in stream:
  File "C:\Program Files\VisualSVN Server\trac\python\lib\site-packages\genshi-0.6-py2.6.egg\genshi\template\markup.py", line 316, in _strip
    event = next()
  File "C:\Program Files\VisualSVN Server\trac\python\lib\site-packages\genshi-0.6-py2.6.egg\genshi\template\base.py", line 545, in _flatten
    for kind, data, pos in stream:
  File "C:\Program Files\VisualSVN Server\trac\python\lib\site-packages\genshi-0.6-py2.6.egg\genshi\core.py", line 288, in _ensure
    for event in stream:
  File "C:\Program Files\VisualSVN Server\trac\python\lib\site-packages\genshi-0.6-py2.6.egg\genshi\path.py", line 588, in _generate
    subevent = next()
  File "C:\Program Files\VisualSVN Server\trac\python\lib\site-packages\genshi-0.6-py2.6.egg\genshi\template\base.py", line 605, in _include
    for event in stream:
  File "C:\Program Files\VisualSVN Server\trac\python\lib\site-packages\genshi-0.6-py2.6.egg\genshi\template\markup.py", line 316, in _strip
    event = next()
  File "C:\Program Files\VisualSVN Server\trac\python\lib\site-packages\genshi-0.6-py2.6.egg\genshi\template\base.py", line 565, in _flatten
    result = _eval_expr(data, ctxt, vars)
  File "C:\Program Files\VisualSVN Server\trac\python\lib\site-packages\genshi-0.6-py2.6.egg\genshi\template\base.py", line 277, in _eval_expr
    retval = expr.evaluate(ctxt)
  File "C:\Program Files\VisualSVN Server\trac\python\lib\site-packages\genshi-0.6-py2.6.egg\genshi\template\eval.py", line 178, in evaluate
    return eval(self.code, _globals, {'__data__': data})
  File "D:\PM\Trac\.egg-cache\trac-0.12.3-py2.6-win32.egg-tmp\trac\templates\error.html", line 165, in <Expression u'shorten_line(repr(value))'>
    <td><code>${shorten_line(repr(value))}</code></td>
  File "C:\Program Files\VisualSVN Server\trac\python\lib\site-packages\trac-0.12.3-py2.6-win32.egg\trac\mimeview\api.py", line 170, in __repr__
    path.append(repr(context.resource))
  File "C:\Program Files\VisualSVN Server\trac\python\lib\site-packages\trac-0.12.3-py2.6-win32.egg\trac\resource.py", line 118, in __repr__
    return '<Resource %r>' % (', '.join(reversed(path)))
TypeError: sequence item 0: expected string, WikiPage found


Attachments (0)

Change History (4)

comment:1 Changed 2 years ago by rjollos

  • Description modified (diff)
  • Status changed from new to assigned

comment:2 Changed 2 years ago by rjollos

(In [11803]) Refs #10189: Attachment TracLinks were not being rendered correctly. Context.from_request needs a Resource objects as its second argument.

comment:3 Changed 2 years ago by rjollos

  • Reporter changed from anonymous to swsm@…

I wasn't able to reproduce the error you reported, but I did observe that attachment TracLinks were not being rendered as links. Let me know if the latest change fixes the issue for you. Thanks.

comment:4 Changed 2 years ago by rjollos

  • Resolution set to fixed
  • Status changed from assigned to closed

I'm assuming the issue has been fixed since there is no reply. Please continue the discussion if you find any issues.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.