Modify

Opened 8 years ago

Closed 7 years ago

#1035 closed defect (fixed)

Internal error when trying to create a new code review

Reported by: anonymous Owned by: Team5
Priority: normal Component: PeerReviewPlugin
Severity: critical Keywords: Clearsilver Tag Parse Error
Cc: Trac Release: 0.10

Description

Following the nav link to create a new code review results in "Trac detected an internal error".

Traceback:

Traceback (most recent call last):
  File "C:\Python\Lib\site-packages\trac\web\main.py", line 387, in dispatch_request
    dispatcher.dispatch(req)
  File "C:\Python\Lib\site-packages\trac\web\main.py", line 244, in dispatch
    req.display(template, content_type or 'text/html')
  File "C:\Python\Lib\site-packages\trac\web\api.py", line 358, in display
    data = self.hdf.render(template, form_token)
  File "C:\Python\Lib\site-packages\trac\web\clearsilver.py", line 296, in render
    injector.feed(template.render())
  File "C:\Python\Lib\HTMLParser.py", line 108, in feed
    self.goahead(0)
  File "C:\Python\Lib\HTMLParser.py", line 148, in goahead
    k = self.parse_starttag(i)
  File "C:\Python\Lib\HTMLParser.py", line 226, in parse_starttag
    endpos = self.check_for_whole_start_tag(i)
  File "C:\Python\Lib\HTMLParser.py", line 301, in check_for_whole_start_tag
    self.error("malformed start tag")
  File "C:\Python\Lib\HTMLParser.py", line 115, in error
    raise HTMLParseError(message, self.getpos())
HTMLParseError: malformed start tag, at line 269, column 36

Trac version: 0.10.3

Attachments (1)

trac.patch (916 bytes) - added by akhavr@… 7 years ago.
Trac patch that hides the problem

Download all attachments as: .zip

Change History (11)

comment:1 Changed 8 years ago by rob.sharp@…

I'm also seeing this on trac 0.10.3 on rhel4 with python 2.3

comment:2 Changed 8 years ago by anonymous

  • Keywords Clearsilver Tag Parse Error added
  • Severity changed from normal to major

Same here on OpenSuSE 10.2 .
I think I remember reading that there's a patch for clearsilver to fix this...
I'll look around ... and report back

comment:3 Changed 7 years ago by DPadbury@…

Reproduced on Trac 0.10.3 on Windows 2003 with Python 2.4.

comment:4 Changed 7 years ago by anonymous

  • Severity changed from major to critical

comment:5 Changed 7 years ago by eric@…

Also a bug on FreeBSD w/ Python 2.4, Trac 0.10.3.

comment:6 Changed 7 years ago by akhavr@…

Confirmed on trac-0.10.3 and python 2.4. Any progress/updates here?

Changed 7 years ago by akhavr@…

Trac patch that hides the problem

comment:7 Changed 7 years ago by akhavr@…

Attached patch to trac hides the problem by surrounding the verification by try-except pair.

comment:8 Changed 7 years ago by rob.sharp@…

Thanks for that patch akhavr, but it looks like the source of the issue is now apparent:

"No handler matched request to /peerReviewBrowser"

Am i missing something?

comment:9 Changed 7 years ago by akhavr@…

No, Rob, I don't get such error. As I mentioned here, after this ticket issue is hidden by the patch above, the #938 pops up, which requires much more deep experience with the plugin.

Linux, apache 2.0.55, mod_python 3.1.4, trac 0.10.3, python 2.4.2

comment:10 Changed 7 years ago by mikechml

  • Resolution set to fixed
  • Status changed from new to closed

(In [2270]) fixes #938, #1035
refs #650

Moved large portions of javascript to external files to avoid parser errors, and keep it tidy.
Fixes for preview_to_hdf.
Should now work with 0.10

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from Team5. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.