Modify

#10399 closed defect (invalid)

DatabaseError: database disk image is malformed

Reported by: dpal Owned by:
Priority: normal Component: SELECT A HACK
Severity: normal Keywords:
Cc: hasienda Trac Release: 0.12

Description

How to Reproduce

While doing a GET operation on /report/3, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'id': u'3'}

User agent: #USER_AGENT#

System Information

Trac 0.12.3
Babel 0.9.4
Bazaar 2.1.1
CustomFieldAdmin 0.2.6
Docutils 0.6
Genshi 0.6
GIT 1.7.2.1
Mercurial 1.4
mod_wsgi 3.2 (WSGIProcessGroup WSGIApplicationGroup %{GLOBAL})
Pygments 1.1.1
pysqlite 2.3.5
Python 2.6.6 (r266:84292, Aug 28 2012, 10:56:20)
[GCC 4.4.6 20120305 (Red Hat 4.4.6-4)]
pytz 2010h
RPC 1.1.0
setuptools 0.6
SQLite 3.6.20
Subversion 1.6.11 (r934486)
TracBzr 0.4.2
jQuery #JQUERY#

Enabled Plugins

BatchModify 0.8.0-trac0.12
IniAdmin 0.2
NavAdd 0.1
TracBzr 0.4.2
TracCustomFieldAdmin 0.2.6
TracGit 0.12.0.5dev
TracMercurial 0.12.0.23dev-r9953
TracTocMacro 11.0.0.3
TracXMLRPC 1.1.0

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/trac/web/main.py", line 525, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.6/site-packages/trac/web/main.py", line 269, in dispatch
    req.session.save()
  File "/usr/lib/python2.6/site-packages/trac/web/session.py", line 105, in save
    @self.env.with_transaction()
  File "/usr/lib/python2.6/site-packages/trac/db/api.py", line 77, in transaction_wrapper
    fn(ldb)
  File "/usr/lib/python2.6/site-packages/trac/web/session.py", line 140, in save_session
    """, (self.sid, authenticated))
  File "/usr/lib/python2.6/site-packages/trac/db/util.py", line 65, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/usr/lib/python2.6/site-packages/trac/db/sqlite_backend.py", line 78, in execute
    result = PyFormatCursor.execute(self, *args)
  File "/usr/lib/python2.6/site-packages/trac/db/sqlite_backend.py", line 56, in execute
    args or [])
  File "/usr/lib/python2.6/site-packages/trac/db/sqlite_backend.py", line 48, in _rollback_on_error
    return function(self, *args, **kwargs)
DatabaseError: database disk image is malformed

Attachments (0)

Change History (1)

comment:1 Changed 22 months ago by rjollos

  • Cc hasienda added
  • Resolution set to invalid
  • Status changed from new to closed

The traceback doesn't give any information about this being associated with a particular plugin. It looks like it is most likely an installation issue. First though, you could try disabling all plugins to be sure. If that doesn't lead to a specific plugin to which the issue can be assigned, I suggest asking over on the t:MailingList.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from (none). Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.