Modify

Opened 22 months ago

Closed 22 months ago

Last modified 22 months ago

#10487 closed defect (fixed)

Plugin doesn't load using setuptools develop command

Reported by: rjollos Owned by: olemis
Priority: normal Component: PyTppThemePlugin
Severity: normal Keywords: setuptools develop
Cc: Trac Release: 0.12

Description

I see this error when starting Trac:

02:28:19 PM Trac[loader] ERROR: Skipping "pytpptheme.theme = pytpptheme.theme": (can't import "ImportError: No module named pytpptheme.theme")

One way to fix the issue is to just rename the pytppthemeplugin/0.11/pydotorgtheme@7223 to pytppthemeplugin/0.11/pytpptheme. Alternatively, the attached patch can be used.

Attachments (1)

th10487.patch (447 bytes) - added by rjollos 22 months ago.
Patch against r7223 of the plugin.

Download all attachments as: .zip

Change History (5)

Changed 22 months ago by rjollos

Patch against r7223 of the plugin.

comment:1 Changed 22 months ago by rjollos

I don't think the attached patch is the correct way to fix this, because it appears that the directory was just misnamed. So probably just a directory rename is all that is needed to fix the issue.

comment:2 Changed 22 months ago by rjollos

  • Resolution set to fixed
  • Status changed from new to closed

(In [12240]) Fixes #10487: Fixed misnamed directory.

comment:3 Changed 22 months ago by olemis

  • Keywords setuptools develop added
  • Summary changed from Plugin doesn't load to Plugin doesn't load using setuptools develop command

I appreciate your feedback . Initially I was thinking of reverting them because since the beginning I had in mind not to change that folder name . Notice that even if your changes make it work from fresh svn checkout + setuptools develop command (that's why /me not reverting [12240] ) , in the end it will break distutils sdist and bdist* commands . Hence I've committed [12242] .

In the future it'd be nice if you please could mention proposed changes in the form of a patch and wait for me to review and give green light before committing changes .

comment:4 Changed 22 months ago by olemis

or better ...are you ok with creating a patch queue at bitbucket so that you (and others) can hack the code and submit patches in an organized manner ?

wiki:olemis#Guidelinestocollaborate

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from olemis. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.