Modify

#10618 closed defect (fixed)

Error with MySQL and TRAC 0.12.4

Reported by: martin.fernholz@… Owned by: sandinak
Priority: normal Component: DirectoryAuthPlugin
Severity: blocker Keywords:
Cc: Trac Release: 0.12

Description

I installed TracDirectoryAuth 0.5 with TRAC 0.12.4, MySQL 5.1.63 and AccountManager 0.3.2. After I activate the TracDirectoryAuth Plugin

tracext.adauth.api.userextensiblepermissionstore = enabled
tracext.adauth.auth.adauthstore = enabled
tracext.adauth.db.activedirectoryauthpluginsetup = enabled

and edit the trac.ini as at the projectpage shown I try to upgrade my project environment. Here I get this error message:

ProgrammingError: (1064, "You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'varcahar(32),\n    `lut` int,\n    `data` binary,\n    PRIMARY KEY (`id`)\n)' at line 2")

Any idea what's wrong?

Attachments (0)

Change History (7)

comment:1 Changed 21 months ago by anonymous

I thinks it's invalid column type "varcahar". Fixed it and schema upgrade went smoothly.

comment:2 follow-up: Changed 21 months ago by martin.fernholz@…

  • Resolution set to fixed
  • Status changed from new to closed

Thx to "anonymous" for the silly hint. The error is in the file db.py in line 23. I tryed to update the source but I haven't a login for svn.

@sandinak: Please fix it.

Problem is fixed for me.

comment:3 in reply to: ↑ 2 Changed 16 months ago by rjollos

Replying to martin.fernholz@atm-computer.de:

@sandinak: Please fix it.

Problem is fixed for me.

It is more likely to get fixed if you leave the ticket open until the issue is actually resolved in the codebase.

comment:4 Changed 16 months ago by rjollos

(In [12776]) Refs #10618: Fixed typo in database schema.

comment:5 Changed 16 months ago by rjollos

  • Resolution fixed deleted
  • Status changed from closed to reopened

[12776] was reverted by the plugin author in [12971] and [12972], so the issue persists following r12972.

comment:6 Changed 15 months ago by anonymous

This issue also reported in postgresql DB back end(Testing on trac 1.0 )

Run "trac-admin /opt/trac upgrade"

trac@trac:/etc/apache2/sites-enabled$ trac-admin /opt/trac upgrade
Error: Error reading '/opt/trac/conf/trac.ini', make sure it is readable.
trac@trac:/etc/apache2/sites-enabled$ sudo trac-admin /opt/trac upgrade
The upgrade failed. Please fix the issue and try again.

ProgrammingError: type "varcahar" does not exist
LINE 2:     "id" varcahar(32) PRIMARY KEY,
                 ^

comment:7 Changed 15 months ago by rjollos

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [13074]) Fixes #10618: Fixed typo into DB schema. This had previously been fixed in [12776], but the change was reverted by the plugin author for unknown reason.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from sandinak. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.