Modify

Opened 8 years ago

Closed 8 years ago

#1062 closed defect (invalid)

Links inside headers messes up output

Reported by: anonymous Owned by: coderanger
Priority: normal Component: TocMacro
Severity: normal Keywords:
Cc: Trac Release: 0.10

Description

If there are links inside the text of a heading, then the full original text gets copied into the table of contents, including the opening square bracket etc. Instead, TocMacro should strip out the formatting and just use the wiki text that would be shown in the main page.

Attachments (0)

Change History (1)

comment:1 Changed 8 years ago by mnw21@…

  • Resolution set to invalid
  • Status changed from new to closed

My apologies, this is not a bug in TocMacro. The bug exists in Trac, in the call to shorten_line in OneLinerFormatter in trac/wiki/formatter.py

Add Comment

Modify Ticket

Action
as closed The owner will remain coderanger.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.