Modify

Opened 2 years ago

Closed 2 days ago

#10639 closed enhancement (duplicate)

Include just a part of a wiki page

Reported by: tsari Owned by: rjollos
Priority: normal Component: IncludeMacro
Severity: normal Keywords:
Cc: Trac Release: 0.12

Description (last modified by rjollos)

The IncludeMacro allows you to inlcude full wiki pages into another page. This is useful, but I want to include just a part of a wiki page.

How should the macro work?

  • specify the part which should be included, e.g. [[IncludePart(PAGE_URL, HEADLINE)]]

So the marco should scan the page which exists under PAGE_URL for a headline tag with the content HEADLINE. It should recognize the type of headline (h1...h6) and get the content underneath up to the next headline with the same type or the page end.

Thanks a lot

Attachments (0)

Change History (6)

comment:1 Changed 2 years ago by tsari

  • Owner changed from anybody to rjollos

Hey,

I'd really appreciate it if you could have a look on my thoughts to improve your plug-in.

Regards, tsari

comment:2 Changed 2 years ago by rjollos

  • Component changed from Request-a-Hack to IncludeMacro

IIRC, there is a similar ticket for IncludeMacro. Let's move the ticket over there and I'll try to find some time to take a look.

comment:3 Changed 23 months ago by rjollos

  • Description modified (diff)

comment:4 Changed 13 months ago by rjollos

  • Status changed from new to assigned

comment:5 Changed 5 months ago by oailloud@…

This would be useful for me too to prevent uglies copies/pastes... Thanks !

comment:6 Changed 2 days ago by rjollos

  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate of #9537.

Add Comment

Modify Ticket

Action
as closed The owner will remain rjollos.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.