Modify

Opened 2 years ago

Closed 19 months ago

Last modified 19 months ago

#10698 closed task (invalid)

Support for Trac 1.0

Reported by: comy01@… Owned by: eblot
Priority: normal Component: LdapPlugin
Severity: major Keywords: group
Cc: Trac Release: 1.0

Description

LdapPlugin seems not working on Trac 1.0

Attachments (0)

Change History (12)

comment:1 Changed 2 years ago by rjollos

What errors or problems do you see? The plugin author will certainly need more details than you've provided!

comment:2 Changed 2 years ago by anonymous

Maybe this might help?

17:20:51 Trac[loader] DEBUG: Loading ldapplugin.api from /usr/lib/python2.6/site-packages/LdapPlugin-0.6.0dev_r5686-py2.6.egg
17:20:51 Trac[loader] ERROR: Skipping "ldapplugin.api = ldapplugin.api": (version conflict "VersionConflict: (Trac 1.0 (/usr/lib/python2.6/site-packages/Trac-1.0-py2.6.egg), Requirement.parse('Trac<0.13'))")

comment:3 Changed 2 years ago by rjollos

The plugin author imposed that restriction in [10934]. I suggest deleting install_requires = [ 'Trac>=0.12', 'Trac<0.13'] from setup.py and seeing if it just works. There's a good chance it will.

comment:4 follow-up: Changed 20 months ago by andrex

I tried that: set install_requires = [ 'Trac>=0.12' ] in setup.py, built and installed the plugin, configured and enabled it. When I did that, every query to Trac hung and never came back. I tried setting log_level=DEBUG, but got nothing at all from the plugin in the Trac log.

comment:5 in reply to: ↑ 4 Changed 19 months ago by rjollos

Replying to andrex:

When I did that, every query to Trac hung and never came back. I tried setting log_level=DEBUG, but got nothing at all from the plugin in the Trac log.

Do you mean that the Trac pages don't load?

comment:6 Changed 19 months ago by andrex

  • Resolution set to invalid
  • Status changed from new to closed

Yes, that's what I meant.

But it turns out that this was caused by a misconfiguration of my LDAP settings. Trac was trying to contact my server on an LDAPS port, with use_tls = false. The connection hung, and so did Trac. So that was my fault, not the plugin's.

With my LDAP settings corrected and with the above modification, the plugin does work fine in Trac 1.0. Unfortunately though, it causes a long delay on first load, or whenever the LDAP cache expires.

Sorry for the noise.

comment:7 follow-up: Changed 19 months ago by rjollos

eblot: is it okay if we remove the restriction Trac < 0.13, since the 0.12 branch of the plugin has been reported to work with Trac 1.0?

comment:8 in reply to: ↑ 7 ; follow-up: Changed 19 months ago by eblot

Replying to rjollos:

eblot: is it okay if we remove the restriction Trac < 0.13, since the 0.12 branch of the plugin has been reported to work with Trac 1.0?

Feel free: I have no time to work on this plugin anymore.

comment:9 Changed 19 months ago by rjollos

(In [13174]) Refs #10698: Removed Trac < 0.13 restriction from setup.py in 0.12 branch. Plugin has been reported to work with Trac 1.0.

comment:10 in reply to: ↑ 8 ; follow-up: Changed 19 months ago by rjollos

Replying to eblot:

Feel free: I have no time to work on this plugin anymore.

Thanks. Shall I tag it with needsadoption, or do you think you might return to it someday?

I've tagged the project wiki page with 1.0 and added a note about the 0.7.x series working with Trac 1.0.

comment:11 in reply to: ↑ 10 ; follow-up: Changed 19 months ago by eblot

Replying to rjollos:

Thanks. Shall I tag it with needsadoption, or do you think you might return to it someday?

Sure, you can. I thought it had been already 'adopted'.

comment:12 in reply to: ↑ 11 Changed 19 months ago by rjollos

Replying to eblot:

Sure, you can. I thought it had been already 'adopted'.

Not that I know of. I don't see any other committers or tickets requesting adoption.

Add Comment

Modify Ticket

Action
as closed The owner will remain eblot.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.