Modify

#10730 closed defect (fixed)

AccountGuard.lock_time effectively disables account locking

Reported by: hasienda Owned by: hasienda
Priority: high Component: AccountManagerPlugin
Severity: major Keywords: account locking
Cc: rjollos Trac Release: 0.11

Description

Even worse: This has been backed by a plain-wrong unit test assertion and current lack of cross-method (functional) unit tests.

Attachments (0)

Change History (3)

comment:1 Changed 19 months ago by hasienda

  • Status changed from new to assigned

Too bad, that I recognized that only after pushing acct_mgr-0.4.1 out.

Plan is to fix this ASAP (done, testing here) and push another maintenance release. Sorry for the inconvenience caused by this bug so far.

comment:2 Changed 19 months ago by hasienda

(In [12483]) AccountManagerPlugin: Re-enable account locking, #10730.

This has been broken by recent account guard re-work, or worse (if earlier).
Another unit test in addition to the corrected one account for this regession.

comment:3 Changed 19 months ago by hasienda

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [12484]) AccountManagerPlugin: Publish maintenance release 0.4.2, closes #10730.

This is another update for current stable acct_mgr-0.4 to immediatly push the
fix broken account locking.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from hasienda. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.