Modify

Opened 21 months ago

Last modified 4 weeks ago

#10732 accepted enhancement

Use Sortable widget from jQuery UI

Reported by: rjollos Owned by: rjollos
Priority: normal Component: AdminEnumListPlugin
Severity: normal Keywords:
Cc: jun66j5 Trac Release:

Description

jQuery UI 1.6 can be used with jQuery 1.2.6, which would make the plugin compatible down to Trac 0.11.1. See #10331 for more details.

Attachments (0)

Change History (13)

comment:1 Changed 21 months ago by anonymous

  • Type changed from task to enhancement

comment:2 Changed 21 months ago by jun66j5

+1 for me. Most users don't use Trac 0.11.

comment:4 Changed 19 months ago by rjollos

Jun: Sorry for the delay in getting back to you. I plan to test with Trac 0.11, 0.11.1, 1.0.1 and 1.1.2dev. However, the change looks good and I trust you more than myself, so please feel free to push it to the trunk whenever you are ready. After this change is fully tested I think we can tag the 2.0 release and send an announcement to trac-users.

comment:5 Changed 19 months ago by jun66j5

Ok. I'll push it after confirming with each browser within a few days.

comment:6 Changed 19 months ago by jun66j5

(In [12644]) refs #10732: uses Sortable widget from jQuery UI and makes the compatible down to Trac 0.11.1

comment:7 follow-up: Changed 19 months ago by jun66j5

I tested with Trac 0.11 - 0.11.7, 0.12 - 0.12.5, 1.0, 1.0.1 and 1.1.1 on Firefox, Chrome and IE. The some issues is fixed. See https://github.com/jun66j5/adminenumlistplugin/commits/ticket10732.

I just pushed to the trunk! Ryan, could you please test it?

comment:8 in reply to: ↑ 7 Changed 19 months ago by rjollos

Replying to jun66j5:

I tested with Trac 0.11 - 0.11.7, 0.12 - 0.12.5, 1.0, 1.0.1 and 1.1.1 on Firefox, Chrome and IE.

Your thoroughness is impressive!

I just pushed to the trunk! Ryan, could you please test it?

Yes, I will try to find some time to test this weekend. Thanks!

comment:9 Changed 9 months ago by rjollos

  • Status changed from new to accepted

It seems that I dropped the ball on this one. I'll do some testing so we can finally get this released, and then update trac:#10994 with proposed changes to be integrated in the Trac core.

comment:10 Changed 4 weeks ago by rjollos

In 14118:

2.0: Release 2.0. Refs #10732.

  • Refactored jQuery selectors.
  • jQuery files were not being correctly installed.

comment:11 Changed 4 weeks ago by rjollos

Officially released version 2.0 in [14127]. The package has been uploaded to PyPI.

Jun, if you wish to send your PyPI username (or create an account), I'd gladly add you as a package owner.

Last edited 4 weeks ago by rjollos (previous) (diff)

comment:12 Changed 4 weeks ago by jun66j5

Oh, Thanks. I just created a PyPI account, jun66j5.

comment:13 Changed 4 weeks ago by rjollos

Thanks, added you for TracAdminEnumListPlugin and TracAutocompleteUsersPlugin.

Add Comment

Modify Ticket

Action
as accepted .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.