Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#1078 closed defect (fixed)

no attribute 'get_lexer_by_name'

Reported by: mortonda@… Owned by: mgood
Priority: normal Component: TracPygmentsPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.10

Description

Trac[api] WARNING: HTML preview using <tracpygments.PygmentsRenderer object at 0xb798418c> failed ('module' object has no attribute 'get_lexer_by_name') Traceback (most recent call last):   File "/usr/lib/python2.3/site-packages/trac/mimeview/api.py", line 448, in render     filename, url)   File "build/bdist.linux-i686/egg/tracpygments/__init__.py", line 77, in render   File "build/bdist.linux-i686/egg/tracpygments/__init__.py", line 112, in _format AttributeError: 'module' object has no attribute 'get_lexer_by_name'

Centos 4.2 Trac 0.10.3

Attachments (0)

Change History (2)

comment:1 Changed 8 years ago by mgood

  • Resolution set to fixed
  • Status changed from new to closed

(In [1851]) change import for get_lexer_by_name to be compatible with Pygments 0.6 (fixes #1078)

comment:2 Changed 8 years ago by mortonda@…

Yes, confirmed, works for me now. Thanks!

Off topic question, can we chosse alternate highlighting schemes?

Add Comment

Modify Ticket

Action
as closed The owner will remain mgood.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.