Modify

Opened 16 months ago

Closed 6 months ago

#10946 closed defect (worksforme)

Entries lost, structure for 1.0 changed

Reported by: stoecker Owned by: stoecker
Priority: normal Component: TracMigratePlugin
Severity: normal Keywords:
Cc: Trac Release: 1.0

Description

Hello, this plugin looses additional tables like for votes plugin or spamfilter. It should copy any tables, not only the ones it knows.

sqlite ".tables" command shows all tables.

Also the structure of attachements and other files changed in 1.0, so it no longer macthes the structure in the second copy step.

Attachments (0)

Change History (8)

comment:1 Changed 16 months ago by jun66j5

  • Status changed from new to assigned
  • Trac Release set to 1.0

Humm, first issue is not reproduced with VotePlugin and TracMigratePlugin. The votes table and the records are copied.

Second issue is reproduced. It should copy the files directory instead of attachments.

$ ~/venv/trac/1.0.1/bin/trac-admin ~/var/trac/ticket10946 migrate ~/var/trac/ticket10946-migrate sqlite:db/trac.db
Copying tables:
  attachment table... 1 records.
  auth_cookie table... 1 records.
  cache table... 2 records.
  component table... 2 records.
  enum table... 13 records.
  milestone table... 4 records.
  node_change table... 0 records.
  permission table... 17 records.
  report table... 8 records.
  repository table... 0 records.
  revision table... 0 records.
  session table... 1 records.
  session_attribute table... 1 records.
  ticket table... 0 records.
  ticket_change table... 0 records.
  ticket_custom table... 0 records.
  version table... 2 records.
  votes table... 1 records.
  wiki table... 58 records.
Copying directories:
OSError: [Errno 2] No such file or directory: '/home/jun66j5/var/trac/ticket10946-migrate/attachments'
  attachments directory... $
$ sqlite3 ~/var/trac/ticket10946-migrate/db/trac.db
SQLite version 3.3.6
Enter ".help" for instructions
sqlite> select * from votes;
wiki/WikiStart|foobar|1

comment:2 Changed 16 months ago by jun66j5

(In [12737]) tracmigrate: copy files directory instead of attachments on Trac 1.0+. The attachments directory is moved to files by trac/upgrades/db28.py. (refs #10946)

comment:3 Changed 16 months ago by jun66j5

First issue is not reproduced even with spam filter plugin. This plugin correctly copies spamfilter_bayes and spamfilter_log tables on my environment. Could you please let me know the details?

comment:4 Changed 16 months ago by stoecker

Hmm, my migration is over, so actually I don't need that anymore :-).

I did setup a postgres db from scratch. Took my sqlite db, did migrate. Then it required a trac upgrade and after i checked all data form spamfilter and vote plugin were lost. In the process I did update from 1.0 to 1.0.1, but that should not be the reason.

What info would help you to fix that for other users?

comment:5 Changed 16 months ago by jun66j5

Ok. Thanks for the details! I try to reproduce this weekend.

comment:6 Changed 16 months ago by jun66j5

Unfortunately, still not reproduced on migration from SQLite to PostgreSQL with Trac 1.0.1....

Could you please attach the trac.ini file of Trac as source on migration? If so, please mask any sensitive data in the trac.ini file.

comment:7 Changed 16 months ago by stoecker

  • Owner changed from jun66j5 to stoecker
  • Status changed from assigned to new

I'll try myself on a clean setup when I have time.

comment:8 Changed 6 months ago by stoecker

  • Resolution set to worksforme
  • Status changed from new to closed

I have no time to check at all. Closing.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from stoecker. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.