Modify

Opened 17 months ago

Closed 9 months ago

#11192 closed task (fixed)

Is QueuesPlugin actively maintained?

Reported by: patrick.tripp@… Owned by: rjollos
Priority: normal Component: QueuesPlugin
Severity: normal Keywords: Maintained, Supported
Cc: Trac Release: 0.12

Description

Hi,

I am trying to have QueuesPlugin installed on one of our svn servers and am meeting some resistance. I see the last update to the plugin was about a year and a half ago.

Is the QueuesPlugin plugin actively maintained and supported? Will you make any future bug fixes,enhancements, or upgrades?

Thank you - Patrick

Attachments (0)

Change History (8)

comment:1 in reply to: ↑ description ; follow-up: Changed 17 months ago by rjollos

Replying to patrick.tripp@…:

I am trying to have QueuesPlugin installed on one of our svn servers and am meeting some resistance.

What problems are you having? Debug info (t:TracLogging) would be useful to help you solve your problem.

comment:2 in reply to: ↑ 1 Changed 17 months ago by anonymous

Replying to rjollos:

Replying to patrick.tripp@…:

I am trying to have QueuesPlugin installed on one of our svn servers and am meeting some resistance.

What problems are you having? Debug info (t:TracLogging) would be useful to help you solve your problem.

The admins don't want to install it because it is not being "actively maintained". They are concerned about security issues.

  • Patrick

comment:3 follow-up: Changed 17 months ago by robguttman

This plugin is being actively maintained by me. We use it at my current job regularly.

comment:4 in reply to: ↑ 3 ; follow-up: Changed 17 months ago by anonymous

That is good to know. They were also concerned about the older version of jquery-ui bundled with it. Do you know if it works with jquery-ui 1.10.3 or 1.9.2?

Thanks - Patrick

comment:5 in reply to: ↑ 4 Changed 17 months ago by anonymous

Replying to anonymous:

That is good to know. They were also concerned about the older version of jquery-ui bundled with it. Do you know if it works with jquery-ui 1.10.3 or 1.9.2?

Thanks - Patrick

The admins decided not to install it partly because of the above. If you update your package with a newer version of jquery-ui, I can ask them to reconsider.

Thanks - Patrick

comment:6 Changed 16 months ago by rjollos

Plugins in Trac 1.0 and later can just use jQuery UI bundled with Trac, and when accessing it through the Trac API, [trac] jquery_ui_location can be set to another version of jQuery UI installed locally or available on a CDN (see TracIni#trac-section).

Last edited 9 months ago by rjollos (previous) (diff)

comment:7 Changed 9 months ago by rjollos

  • Owner changed from robguttman to rjollos
  • Status changed from new to accepted

comment:8 Changed 9 months ago by rjollos

  • Resolution set to fixed
  • Status changed from accepted to closed

In 13773:

0.2.0dev: In Trac 1.0 and later, use jQuery UI that is bundled with Trac. Fixes #11192.

This also allows using a newer version of jQuery UI in Trac 1.0 and later, by setting the [trac] jquery_ui_location option to serve a file stored locally, or to serve it from a CDN.

Add Comment

Modify Ticket

Action
as closed The owner will remain rjollos.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.