Modify

Opened 9 months ago

Closed 9 months ago

#11238 closed enhancement (fixed)

Please provide a clear license

Reported by: geofft Owned by: retracile
Priority: normal Component: AdvancedTicketWorkflowPlugin
Severity: normal Keywords: license
Cc: Trac Release:

Description

I'm looking at packaging a couple of the Trac plugins we use at my workplace as Debian packages. The license for AdvancedTicketWorkflowPlugin is stated as "BSD" in setup.py, but not clearly stated anywhere. Can you please provide the full text of the license you intend to use? Among other things, there are multiple versions of the BSD license, so "BSD" by itself is ambiguous.

If you're intending to use the same license as Trac itself (the 3-clause BSD license), you can just copy TracLicense and replace the copyright statement at the top with your own name and years of authorship. Commit it as a file called "COPYING", and preferably reference that file from each Python source file. As an example of doing this well, take a look at the source of AutocompleteUsersPlugin, which puts a copyright notice in each source file.

Thanks!

Attachments (0)

Change History (2)

comment:1 Changed 9 months ago by rjollos

  • Keywords license added

I just wanted to mention that I'd be happy to push changes to the repository if you give a preference on the license, but are too busy to deal with making the changes right now.

comment:2 Changed 9 months ago by retracile

  • Resolution set to fixed
  • Status changed from new to closed

Yes, my intent was to align the license with Trac, particularly since this plugin was intended as a proving ground for ticket operations that could potentially become part of Trac itself.

Clarified license committed in [13339] for the 0.11 version and [13338] for the 0.12 version.

Thank you for bringing this to my attention.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from retracile. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.