Modify

#11309 closed defect (worksforme)

ProgrammingError: operator does not exist: text = integerLINE 1: SELECT dest FROM mastertickets WHERE source=2 ORDER BY dest ^HINT: No operator matches the given name and argument type(s). You might need to add explicit type casts.

Reported by: jerry Owned by:
Priority: normal Component: MasterTicketsPlugin
Severity: normal Keywords:
Cc: Trac Release: 1.0

Description

How to Reproduce

While doing a GET operation on /ticket/2, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'id': u'2'}

User agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1547.65 Safari/537.36

System Information

Trac 1.0
Agilo 1.3.10-PRO
Genshi 0.7 (without speedups)
psycopg2 2.0.14
Pygments 1.4
Python 2.6.8 (unknown, Mar 14 2013, 09:31:22)
[GCC 4.6.2 20111027 (Red Hat 4.6.2-2)]
setuptools 0.8
Subversion 1.7.10 (r1485443)
jQuery 1.7.2

Enabled Plugins

binary-agilo 1.3.10-PRO
TestManager 1.7.1
TracAccountManager 0.4.3
TracGenericClass 1.1.5
TracGenericWorkflow 1.0.4
TracMasterTickets 2.1.3
TracPermRedirect 3.0
TracSQL 0.3
TracStats 0.5
TracXMLRPC 0.1

Python Traceback

Traceback (most recent call last):
  File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 497, in _dispatch_request
    dispatcher.dispatch(req)
  File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 224, in dispatch
    self._post_process_request(req, *resp)
  File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 338, in _post_process_request
    resp = f.post_process_request(req, *resp)
  File "build/bdist.linux-x86_64/egg/mastertickets/web_ui.py", line 45, in post_process_request
    links = TicketLinks(self.env, tkt)
  File "build/bdist.linux-x86_64/egg/mastertickets/model.py", line 22, in __init__
    cursor.execute('SELECT dest FROM mastertickets WHERE source=%s ORDER BY dest', (self.tkt.id,))
  File "build/bdist.linux-x86_64/egg/trac/db/util.py", line 65, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
ProgrammingError: operator does not exist: text = integer
LINE 1: SELECT dest FROM mastertickets WHERE source=2 ORDER BY dest
                                                   ^
HINT:  No operator matches the given name and argument type(s). You might need to add explicit type casts.

Attachments (0)

Change History (1)

comment:1 Changed 10 months ago by rjollos

  • Component changed from SELECT A HACK to MasterTicketsPlugin
  • Resolution set to worksforme
  • Status changed from new to closed

Please upgrade your MasterTicketsPlugin install. The issue is most likely fixed already.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from (none). Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.