Modify

#11314 closed defect (worksforme)

Workflow Diagram does not work

Reported by: paresh138@… Owned by: jun66j5
Priority: normal Component: TracWorkflowAdminPlugin
Severity: normal Keywords: workflow diagram
Cc: Trac Release: 1.0

Description

I have Trac 1.0 and TracWorkflowAdmin 0.12.0.2 running on Ubuntu 13.04.

When editing workflows, if I click the Update button on the diagram, I don't get a workflow diagram.

Attachments (3)

trac.log (28.6 KB) - added by paresh138@… 14 months ago.
Screenshot from 2013-09-25 09:41:47.png (100.0 KB) - added by paresh138@… 13 months ago.
Screenshot from 2013-09-25 09:49:58.png (128.2 KB) - added by paresh138@… 13 months ago.

Download all attachments as: .zip

Change History (16)

comment:1 Changed 14 months ago by paresh138@…

I have trac Master tickets installed (3.0.2) and I can get depgraphs of related tickets, so I know that Graphvis is correctly installed & available to trac

comment:2 Changed 14 months ago by jun66j5

Please check errors and warnings in trac.log of your Trac environment after enabling TracLogging if trac.log is missing. If you have the relative logs, could you let me know the logs?

Changed 14 months ago by paresh138@…

comment:3 follow-up: Changed 13 months ago by paresh138@…

Any progress?

I didn't see anything in the logs that would give a clue

comment:4 in reply to: ↑ 3 Changed 13 months ago by jun66j5

Replying to paresh138@…:

Any progress?

Sorry, I hadn't noticed the attachment. Trac doesn't send notification mail when attaching files.

I didn't see anything in the logs that would give a clue

Yeah, it seems no errors and no warnings.

I guess that javascript feature is disabled or javascript errors happened. What your browser are you using? Which version? Also, please check javascript console of your browser.

If the plugin works, the following text will be logged when the browser requests for an image of the workflow diagram.

2013-09-21 05:45:34,342 Trac[main] DEBUG: Dispatching <RequestWithSession "GET '/chrome/site/tracworkflowadmin/41980715afdc0aefb261e2d17863100b.png'">

comment:5 Changed 13 months ago by paresh138@…

OK, we have something of interest here.

Using firebug, I get no errors on the windows machine, but using firefox on my Ubuntu server (which is also running trac), I get something like:

"NetworkError: 404 Not Found - http://localhost/trac/chrome/site/tracworkflowadmin/b18c750060e257ef7ffe3f992079f9cf.png?hlul0hhl"

So, I did a search for the filename and found it in my Trac directory
/var/trac/htdocs/tracworkflowadmin/

The file is 56291 bytes, so there is something in there, but eog cannot display it.

comment:6 follow-up: Changed 13 months ago by paresh138@…

Forget the eog bit, it was a permissions thing :)

The image is there and correctly displays the diagram, so the problem is that trac cannot find the image.

This, I think means that I have a config setting that is wrong, but MasterTickets works (ie the dependency graph is generated and displayed in trac), so that must do something different.

Last edited 13 months ago by rjollos (previous) (diff)

comment:7 in reply to: ↑ 6 Changed 13 months ago by jun66j5

Replying to paresh138@…:

This, I think means that I have a config setting that is wrong, but MasterTickets works (ie the dependency graph is generated and displayed in trac), so that must do something different.

Hmm, it seems that masterticketsplugin generates a image for every request and doesn't save the image to the disk.

Please make sure that your web server or Trac can read the file in $ENV/htdocs directory.

ls -l $ENV/htdocs $ENV/htdocs/tracworkflowadmin
chmod -R a+r $ENV/htdocs

comment:8 follow-up: Changed 13 months ago by paresh138@…

well, starting with an empty directory, the ls command gives

/var/trac/htdocs:
total 12
drwxr-sr-x 5 www-data www-data 4096 Aug 28 21:33 common
drwxr-xr-x 2 www-data www-data 4096 Aug 28 11:13 site
drwxr-xr-x 2 www-data www-data 4096 Sep 22 13:14 tracworkflowadmin

/var/trac/htdocs/tracworkflowadmin:
total 0

After pressing update on workflow admin I get

/var/trac/htdocs:
total 12
drwxr-sr-x 5 www-data www-data 4096 Aug 28 21:33 common
drwxr-xr-x 2 www-data www-data 4096 Aug 28 11:13 site
drwxr-xr-x 2 www-data www-data 4096 Sep 24 07:17 tracworkflowadmin

/var/trac/htdocs/tracworkflowadmin:
total 44
-rw------- 1 www-data www-data 41162 Sep 24 07:17 4101bf4517d68c57c6325d7709fe0f79.png

At this point, I cannot view the image using eog, unless I use an admin account (sudo eog ...), and the image is not displayed on the workflow admin page.

Finally, after the chmod command, I have

/var/trac/htdocs:
total 12
drwxr-sr-x 5 www-data www-data 4096 Aug 28 21:33 common
drwxr-xr-x 2 www-data www-data 4096 Aug 28 11:13 site
drwxr-xr-x 2 www-data www-data 4096 Sep 24 07:17 tracworkflowadmin

/var/trac/htdocs/tracworkflowadmin:
total 44
-rw-r--r-- 1 www-data www-data 41162 Sep 24 07:17 4101bf4517d68c57c6325d7709fe0f79.png

which can be viewed as a normal user with eog, but still does not show in workflow admin, even when I refresh the page.

On the browser console, I get this error

"NetworkError: 404 Not Found - http://localhost/trac/chrome/site/tracworkflowadmin/4101bf4517d68c57c6325d7709fe0f79.png?hlyr1ewx"

but the file is present.

comment:9 in reply to: ↑ 8 Changed 13 months ago by jun66j5

Replying to paresh138@…:
Thanks for the details.

"NetworkError: 404 Not Found - http://localhost/trac/chrome/site/tracworkflowadmin/4101bf4517d68c57c6325d7709fe0f79.png?hlyr1ewx"

When the URL is requested from your browser, you will get one of the following logs.

2013-09-xx xx:xx:xx,xxx Trac[main] DEBUG: Dispatching <RequestWithSession "GET '/chrome/site/tracworkflowadmin/4101bf4517d68c57c6325d7709fe0f79.png'">

Or

2013-09-24 16:10:38,948 Trac[chrome] WARNING: File tracworkflowadmin/4101bf4517d68c57c6325d7709fe0f79.png not found in any of ['/home/jun66j5/var/trac/0.13/htdocs']
2013-09-24 16:10:38,949 Trac[main] WARNING: [192.168.11.12] HTTPNotFound: 404 Not Found (File tracworkflowadmin/4101bf4517d68c57c6325d7709fe0f79.png not found)

If you don't get any logs in trac.log, your request have not reached to Trac. Please check the configurations of your web server (apache?).

I suppose that issue is an installation issue.

Changed 13 months ago by paresh138@…

comment:10 follow-up: Changed 13 months ago by paresh138@…

I added the second line to my apache config for Trac.

Alias /trac/chrome/common /var/trac/htdocs/common
Alias /trac/chrome/site/tracworkflowadmin /var/trac/htdocs/tracworkflowadmin
Alias /trac/chrome/site /var/trac/htdocs/site

It has to be there because otherwise apache complains about overlapping paths.

I now get the image displayed correctly, but I've found another issue - :)

Looking at the attachment, new actions do not show on the image, but new statuses do.

Changed 13 months ago by paresh138@…

comment:11 in reply to: ↑ 10 Changed 13 months ago by jun66j5

Looking at the attachment, new actions do not show on the image, but new statuses do.

The plugin doesn't show actions which has * as Next status because such actions don't change the status.

comment:12 Changed 13 months ago by paresh138@…

Of course, that makes sense.

It all works now, thanks for your help.

comment:13 Changed 13 months ago by jun66j5

  • Resolution set to worksforme
  • Status changed from new to closed

You're welcome ;-)

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.