Modify

Opened 5 months ago

Closed 5 months ago

Last modified 5 months ago

#11423 closed defect (fixed)

The components are duplicated in admin page

Reported by: t2y Owned by: rjollos
Priority: normal Component: DefaultCcPlugin
Severity: normal Keywords:
Cc: Trac Release: 1.0

Description

The components are duplicated on Components page in admin panel when DefaultCCAdmin is enabled.

My environment are:

  • DefaultCc-0.3dev_r13333
  • Trac-1.0.2dev_r12281

It seems that the save process is fine, this bug is only for display in admin page.

141                     filter = filter.append(tag.tr(tag.td(tag.input(type='checkbox', name='sel', value=comp.name), class_='sel'),
142                                                   tag.td(tag.a(comp.name, href=req.href.admin('ticket', 'components') + '/' + comp.name), class_='name'),
143                                                   tag.td(comp.owner, class_='owner'),
144                                                   tag.td(default_tag, class_='default'),
145                                                   tag.td(default_cc, class_='defaultcc')))

Attachments (1)

defaultcc_admin_components1.png (55.6 KB) - added by t2y 5 months ago.

Download all attachments as: .zip

Change History (6)

Changed 5 months ago by t2y

comment:1 Changed 5 months ago by t2y


comment:2 Changed 5 months ago by rjollos

It appears this might somehow be due to [trac 11919]. Previously, it seems that exhausting the iterator would cause the table to not be rendered, therefore the original author recreated the entire table in Genshi. After 1.0.2dev-r11919, the original table and recreated table are rendered.

Last edited 5 months ago by rjollos (previous) (diff)

comment:3 Changed 5 months ago by rjollos

  • Resolution set to fixed
  • Status changed from new to closed

In 13445:

0.3dev: After Trac 1.0.2dev-r11919, duplicate entries would appear in the table. Fixes #11423,

With components having been cast to a list in the template data dictionary, it has been possible to simplify the filter_stream implementation. It is no longer necessary to recreate the entire table, rather we can just append the "defaultcc" data to the table rows.

comment:4 Changed 5 months ago by rjollos

I fixed some other issues in [13446:13449]. Please let me know if you spot any problems.

comment:5 Changed 5 months ago by t2y

I updated from trunk and confirmed it works well.
Thank you for quick response!

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from rjollos. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.