Modify

Opened 8 months ago

Closed 7 months ago

Last modified 7 months ago

#11433 closed defect (fixed)

ProgrammingError: (1064, "You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '== 'status' \n ORDER BY tc.time' at line 4")

Reported by: zinway.liu@… Owned by: rjollos
Priority: normal Component: TracTicketStatsPlugin
Severity: normal Keywords:
Cc: tuhui@… Trac Release: 1.0

Description

How to Reproduce

While doing a GET operation on /ticketstats, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{}

User agent: Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/33.0.1712.4 Safari/537.36

System Information

Trac 1.0.1
Trac 1.0.1
Babel 0.9.4
Docutils 0.6
Genshi 0.6 (without speedups)
mod_wsgi 3.4 (WSGIProcessGroup WSGIApplicationGroup %{GLOBAL})
MySQL server: "5.1.71", client: "5.1.71", thread-safe: 1
MySQLdb 1.2.3c1
Pygments 1.4
Python 2.6.6 (r266:84292, Nov 22 2013, 12:16:22)
[GCC 4.4.7 20120313 (Red Hat 4.4.7-4)]
Python 2.6.6 (r266:84292, Nov 22 2013, 12:16:22)
[GCC 4.4.7 20120313 (Red Hat 4.4.7-4)]
pytz 2010h
pytz 2010h
setuptools 0.6
setuptools 0.6
Subversion 1.7.4 (r1295709)
jQuery 1.7.2

Enabled Plugins

AutocompleteUsers 0.4.2dev-r0
CKIntegration 1.1dev
GridModify 0.1.6dev-r0
IniAdmin 0.3-r0
LoomingClouds 0.12r1
TicketCalendarPlugin 0.12.0.2
TracAccountManager 0.5dev-r0
TracAnnouncer 1.0dev-r0
TracCAS 2.0.1
TracCustomFieldAdmin 0.2.8-r0
TracDragDrop 0.12.0.11-r0
TracPermRedirect 3.0
TracSubcomponents 1.2.0
TracTags 0.6
TracTicketCharts 0.2dev-r0
Tracticketstats 3.0.0dev-r0
TracUserManagerPlugin 0.5dev-r0
TracWorkflowAdmin 0.12.0.2

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/Trac-1.0.1-py2.6.egg/trac/web/main.py", line 497, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.6/site-packages/Trac-1.0.1-py2.6.egg/trac/web/main.py", line 214, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.6/site-packages/Tracticketstats-3.0.0dev_r0-py2.6.egg/ticketstats/ticketstats.py", line 119, in process_request
    last_num_open = get_num_open_tix(db, last_date, milestone)
  File "/usr/lib/python2.6/site-packages/Tracticketstats-3.0.0dev_r0-py2.6.egg/ticketstats/ticketstats.py", line 237, in get_num_open_tix
    ORDER BY tc.time""" % milestone_str, args)
  File "/usr/lib/python2.6/site-packages/Trac-1.0.1-py2.6.egg/trac/db/util.py", line 65, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/usr/lib64/python2.6/site-packages/MySQLdb/cursors.py", line 173, in execute
    self.errorhandler(self, exc, value)
  File "/usr/lib64/python2.6/site-packages/MySQLdb/connections.py", line 36, in defaulterrorhandler
    raise errorclass, errorvalue
ProgrammingError: (1064, "You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '== 'status' \n        ORDER BY tc.time' at line 4")

Attachments (6)

no_data.png (13.1 KB) - added by zinway.liu@… 7 months ago.
ts.01.jpg (312.9 KB) - added by zinway.liu@… 7 months ago.
ts.02.jpg (142.5 KB) - added by zinway.liu@… 7 months ago.
ts.03.jpg (697.4 KB) - added by zinway.liu@… 7 months ago.
ts.04.jpg (667.1 KB) - added by zinway.liu@… 7 months ago.
ts.03.00.jpg (603.3 KB) - added by zinway 7 months ago.

Change History (17)

comment:1 Changed 7 months ago by jun66j5

#11447 was closed as duplicate.

comment:2 Changed 7 months ago by rjollos

  • Cc tuhui@… added
  • Status changed from new to accepted

It looks like I've made a pretty stupid error in using the incorrect equality operator. Please report back if the fix I push next works for you.

comment:3 Changed 7 months ago by rjollos

In 13533:

Fix error in equality operator. Refs #11433.

comment:4 Changed 7 months ago by rjollos

  • Resolution set to fixed
  • Status changed from accepted to closed

Please reopen if you find that the issue is not fixed.

Changed 7 months ago by zinway.liu@…

comment:5 Changed 7 months ago by anonymous


Thanks,the error is fixed,but my ticketstats has no data.
How can I debug this?

Last edited 7 months ago by rjollos (previous) (diff)

comment:6 follow-up: Changed 7 months ago by rjollos

Do you think it is an issue with Flash player (#11440), or that the query is incorrect?

comment:7 in reply to: ↑ 6 Changed 7 months ago by zinway.liu@…

Replying to rjollos:

Do you think it is an issue with Flash player (#11440), or that the query is incorrect?

Right click the Flash Player(version:12.0.0.38),it says there is no data.
Maybe there is something wrong with the scripts of using YUI.
Can we just print the data to debug this?

Changed 7 months ago by zinway.liu@…

Changed 7 months ago by zinway.liu@…

Changed 7 months ago by zinway.liu@…

Changed 7 months ago by zinway.liu@…

comment:8 Changed 7 months ago by zinway

I have fixed the issue about no data.


Finally I find that there is no error with the scripts,just something wrong with the cdn of YUI website.





The url of charts.swf is not found,then I download the YUI.zip and use the local js sources.

With a flush,the chart is out. :)

Last edited 7 months ago by zinway (previous) (diff)

comment:9 Changed 7 months ago by rjollos

What version of YUI did you donwload? In #11440, I was suggesting we might try the new version, 3.14.

Version 0, edited 7 months ago by rjollos (next)

comment:10 follow-up: Changed 7 months ago by zinway

2.9.0
The path of js files is different between 2.9.0 and 3.14

Changed 7 months ago by zinway

comment:11 in reply to: ↑ 10 Changed 7 months ago by rjollos

Replying to zinway:

2.9.0
The path of js files is different between 2.9.0 and 3.14

Thanks, I will try to get it resolved in #11440.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from rjollos. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.