Modify

Opened 6 months ago

Closed 6 months ago

Last modified 6 months ago

#11495 closed defect (fixed)

no such table: ad_cache

Reported by: patrick Owned by: patrick
Priority: normal Component: DirectoryAuthPlugin
Severity: normal Keywords: TracDirectoryAuth 1.0.1
Cc: Trac Release: 1.0

Description

Hi,

I noticed the following warning message appearing over and over in my trac log when using the DirectoryAuthPlugin:

Trac[auth] WARNING: _dir_search: db cache update failed. no such table: ad_cache

As the warning message indicates, no ad_cache table exists when I checked the database. It seems that this might be a side-effect of some refactoring.

At db.py#L22 the name of the database created is dir_cache.

Replacing the instances of ad_cache in auth.py fixes this problem and no further warnings are in the log.

I have attached a patch.

Thanks,

Patrick

Attachments (1)

auth_patch.diff (1.3 KB) - added by patrick 6 months ago.
ad_cache to dir_cache patch

Download all attachments as: .zip

Change History (5)

Changed 6 months ago by patrick

ad_cache to dir_cache patch

comment:1 Changed 6 months ago by rjollos

  • Owner changed from sandinak to rjollos
  • Status changed from new to accepted

Duplicate of #11007. Issue had been resolved and fixed but was reverted for unknown reason and without explanation by the author (see comment:11:ticket:11007). I will apply the fix again.

comment:2 Changed 6 months ago by rjollos

  • Resolution set to fixed
  • Status changed from accepted to closed

In 13570:

Replace table name ad_cache with dir_cache in database queries. Fixes #11495.

This change was necessary after [12767]. Patch by patrick.

comment:3 Changed 6 months ago by rjollos

Let's hope it sticks this time around.

comment:4 Changed 6 months ago by rjollos

  • Owner changed from rjollos to patrick

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from patrick. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.