Modify

Opened 9 months ago

Closed 9 months ago

#11502 closed defect (worksforme)

Unable to See XML_RPC permission in Action dropdown under Permissions section for admin.

Reported by: abhinov.pankaj@… Owned by: osimons
Priority: highest Component: XmlRpcPlugin
Severity: normal Keywords:
Cc: olemis Trac Release: 0.11

Description

Unable to See XML_RPC permission in Action dropdown under Permissions section for admin.
Trac release# Trac 0.11.5rc1

Steps#
1.Downloaded xmlrpcplugin-13551 and created an egg using the setup.py file under trunk folder.
2.Browsed the egg file from Browserfrom trac.
3.Added tracrpc.*=enabled in trac.ini file.
4.Restarted the tomcat server.

Issue#Unable to see the plugin listed in the Manage plugins
Also,not able to see xml_rpc in actions dropdown

Attachments (0)

Change History (6)

comment:1 Changed 9 months ago by osimons

See TracLogging - enable DEBUG logging and verify that the plugin loads, alternatively check reported errors.

BTW, 'tomcat server'? For Python? Or is this perhaps just some proxy configuration, with the Python interpreter running in some other process that does not get restarted by your commands?

comment:2 Changed 9 months ago by anonymous

My TRAC is hosted on a Windows server.In logs,I can see that there are some lines informing that plugin was installed.But I dont see any thing like loading for xml rpc plugin..Do i need to move the egg to the Python\site-packaged folder??

comment:3 Changed 9 months ago by osimons

Is the egg built on a Windows machine too, and using same version of Python? I usually discourage using the plugin upload form as no verification is performed, and there are too many possible error situations from user compilation to running code.

Instead get the source on the server and either do setup.py bdist_egg and (re)place the egg in the trac project Plugins folder, or do setup.py install and have the egg installed to global site-packages (and removing any stray eggs in Plugins directories).

Under "About Trac" as TRAC_ADMIN you should see a detailed overview of versions and plugins with install locations. RPC plugin should show up there too. Include more specific details of your installation in this ticket if you need further assistance.

comment:4 Changed 9 months ago by anonymous

The Python used for making egg was Python33 and on the server python27 is installed.
Let me delete all the eggs on server in plugins folder and make the egg on the server itself.
If I still face the issue will come back with some more specific details.

comment:5 Changed 9 months ago by anonymous

Thanks..The problem is solved..:)

comment:6 Changed 9 months ago by osimons

  • Resolution set to worksforme
  • Status changed from new to closed

Good.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.