Modify

#11503 closed defect (worksforme)

RevTree version Conflict error for Trac 1.0.1

Reported by: abhishekkishore@… Owned by: eblot
Priority: normal Component: RevtreePlugin
Severity: normal Keywords:
Cc: Trac Release: 1.0

Description (last modified by jun66j5)

I get following error while trying to launch Trac, post Trac upgrade to v1.0.1. The Apache service crashes there after.

2014-01-16 15:07:53,687 Trac[loader] ERROR: Skipping "revtree.enhancer = revtree.enhancer": (version conflict "VersionConflict: (trac 1.0.1 (c:\jamp\bin\python25\lib\site-packages\trac-1.0.1-py2.5.egg), Requirement.parse('Trac<0.12'))")
2014-01-16 15:07:53,687 Trac[loader] ERROR: Skipping "revtree.optimizer = revtree.optimizer": (version conflict "VersionConflict: (trac 1.0.1 (c:\jamp\bin\python25\lib\site-packages\trac-1.0.1-py2.5.egg), Requirement.parse('Trac<0.12'))")
2014-01-16 15:07:53,687 Trac[loader] ERROR: Skipping "revtree.web_ui = revtree.web_ui": (version conflict "VersionConflict: (trac 1.0.1 (c:\jamp\bin\python25\lib\site-packages\trac-1.0.1-py2.5.egg), Requirement.parse('Trac<0.12'))")

It seems RevTree version is no more compatible with Trac>0.12. How do we avoid the indicated error?

Attachments (0)

Change History (3)

comment:1 Changed 11 months ago by jun66j5

  • Description modified (diff)

It seems to be an installation issue. RevtreePlugin 0.5.x supports only Trac 0.11. Please try 0.6.x which supports Trac 0.12+. See RevtreePlugin#RecentChanges.

comment:2 Changed 11 months ago by rjollos

0.6.x should be installable in Trac 1.0.x after [13609].

comment:3 Changed 10 months ago by eblot

  • Resolution set to worksforme
  • Status changed from new to closed

Works fine on 1.0+

Add Comment

Modify Ticket

Action
as closed The owner will remain eblot.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.