Modify

Opened 6 months ago

Closed 2 months ago

#11559 closed enhancement (duplicate)

Resolver to fetch email addresses from LDAP

Reported by: anonymous Owned by: hasienda
Priority: highest Component: AnnouncerPlugin
Severity: critical Keywords:
Cc: Trac Release:

Description

The AnnouncerPlugin is good but definitively needs a resolver to fetch the email addresses from a LDAP server and resolve the name found in trac fields (reporter, assigned to, owner, cc list, ...) into email addresses.

Possibly configurable in trac.ini as:

[announcer]
email_address_resolvers = SessionEmailResolver, LdapEmailResolver
...

[ldap]
email_attr = mail
name_resolve_by = cn

Please see also
http://trac-hacks.org/ticket/11558#comment:3

Thanks and regards

Attachments (0)

Change History (3)

comment:1 Changed 6 months ago by anonymous

Or with more self explaining labels and for a cleaner trac.ini :

[announcer]
email_address_resolvers = SessionEmailResolver, LdapEmailResolver
resolver_name_by_ldap_attr = cn
resolver_address_by_ldap_attr = mail
...

[ldap]
...
Last edited 6 months ago by rjollos (previous) (diff)

comment:2 follow-up: Changed 2 months ago by jun66j5

I think the issue is a duplicate of #11411.

comment:3 in reply to: ↑ 2 Changed 2 months ago by hasienda

  • Resolution set to duplicate
  • Status changed from new to closed

Replying to jun66j5:

I think the issue is a duplicate of #11411.

Indeed.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from hasienda. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.