Modify

Opened 5 months ago

Closed 5 months ago

Last modified 5 months ago

#11577 closed defect (duplicate)

Cannot show Depgraph

Reported by: anonymous Owned by: rjollos
Priority: high Component: MasterTicketsPlugin
Severity: major Keywords:
Cc: Trac Release:

Description

When I click on the Depgraph link an error occurs, with the following display:

 Trac detected an internal error:

OSError: [Errno 2] No such file or directory


and the following log:

(...)
  File "/usr/lib/python2.7/dist-packages/genshi/template/eval.py", line 178, in evaluate
    return eval(self.code, _globals, {'__data__': data})
  File "/usr/local/lib/python2.7/dist-packages/TracMasterTickets-3.0.5dev_r13319-py2.7.egg/mastertickets/templates/depgraph.html", line 32, in <Expression u"Markup(graph_render('cmapx').decode('utf8'))">
    ${Markup(graph_render('cmapx').decode('utf8'))}
  File "/usr/local/lib/python2.7/dist-packages/TracMasterTickets-3.0.5dev_r13319-py2.7.egg/mastertickets/graphviz.py", line 141, in render
    stderr=subprocess.PIPE)
  File "/usr/lib/python2.7/subprocess.py", line 679, in __init__
    errread, errwrite)
  File "/usr/lib/python2.7/subprocess.py", line 1259, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory

Installed trac 12.5 in debian 7.3 with:

sudo apt-get install trac
sudo apt-get install trac-graphviz
sudo apt-get install trac-mastertickets

What problem could be?

Attachments (0)

Change History (2)

comment:1 Changed 5 months ago by jun66j5

  • Resolution set to duplicate
  • Status changed from new to closed

A duplicate of #10452. See comment:1:ticket:10452.

When graphviz is not installed or dot_path is not configured, this error can result.

Please submit after search the same issue.

comment:2 Changed 5 months ago by anonymous

Thanks!

Apologize for the dupe, was unsure if the same.
The issue is resolved by putting in the trac.ini the following:

[mastertickets]
dot_path = /usr/bin/dot

BTW a meaningful error message would be useful.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from rjollos. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.