Modify

Opened 8 years ago

Closed 7 years ago

#1158 closed defect (worksforme)

Trac cannot seem to recognize TagsWikiModule as the default_handler

Reported by: anonymous Owned by: athomas
Priority: high Component: TagsPlugin
Severity: critical Keywords:
Cc: Trac Release: 0.10

Description (last modified by coderanger)

I have followed all of your instructions: created the egg file with easy_install, ran the setup.py file, then updated trac.ini with all of the lines in the instructions and the default_handler = TagsWikiModule line too. I get the following error:

Python Traceback
Traceback (most recent call last):
  File "C:\Python24\Lib\site-packages\trac\web\main.py", line 387, in dispatch_request
    dispatcher.dispatch(req)
  File "C:\Python24\Lib\site-packages\trac\web\main.py", line 171, in dispatch
    chosen_handler = self.default_handler
  File "C:\Python24\Lib\site-packages\trac\config.py", line 379, in __get__
    raise AttributeError('Cannot find an implementation of the "%s" '
AttributeError: Cannot find an implementation of the "IRequestHandler" interface named "TagsWikiModule".  Please update the option trac.default_handler in trac.ini.

It is also discussed in ticket http://trac.edgewall.org/ticket/4135

Please let me know what is wrong here. I have reviewed the instructions many times and I have followed the instructions.

Attachments (0)

Change History (8)

comment:1 Changed 8 years ago by coderanger

  • Description modified (diff)
  • Keywords default_handler removed

Fixing formatting

comment:2 Changed 8 years ago by athomas

  • Resolution set to worksforme
  • Status changed from new to closed

This is always a configuration problem of some description. Please enable logging, and triple check your configuration.

comment:3 Changed 7 years ago by totti

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I have the same problem... Would have been great to use tags, but I can't find the mistake in the configuration.

Cheers totti

comment:4 Changed 7 years ago by athomas

  • Resolution set to worksforme
  • Status changed from reopened to closed

If you're having problems, jump on the t:wiki:IrcChannel or t:wiki:MailingList. This is not a bug in tags.

comment:5 Changed 7 years ago by mva.led gmail com

I started to have this problem when upgraded to python2.5.

My env is:

OS
Debian lenny
Trac
Trac 0.10
Python
python 2.5

I reintalled TracTags 0.4.1 using easy_install

comment:6 Changed 7 years ago by anonymous

  • Resolution worksforme deleted
  • Status changed from closed to reopened

My trac site is down until this bug is resolved. All the related tickets here are closed and none suggest how to workaround this issue.

comment:7 Changed 7 years ago by coderanger

Be very very sure you are not trying to use the 0.11 version of the plugin with Trac 0.10.

comment:8 Changed 7 years ago by athomas

  • Resolution set to worksforme
  • Status changed from reopened to closed

Add Comment

Modify Ticket

Action
as closed The owner will remain athomas.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.