Modify

Opened 7 months ago

Closed 6 months ago

Last modified 5 months ago

#11581 closed defect (worksforme)

Trac jsGantt plugin failed

Reported by: tsmelyanskiy@… Owned by: ChrisNelson
Priority: high Component: TracJsGanttPlugin
Severity: critical Keywords:
Cc: Trac Release: 1.0

Description (last modified by jun66j5)

Hi

I have a problem with Trac jsGantt plugin
I got the plugin from https://trac-hacks.org/svn/tracjsganttplugin/0.11/. I made *.egg file from setup.py by using python setup.py bdist_egg. After that I installed this egg with easy_install. I put into trac.ini everything what required installation manual. I restart apache, and after I get

TracError: ParsingError: File contains parsing errors: /opt/trac/apps/trac/trac_projects/ARCCN_Trac/conf/trac.ini
	[line 234]: '  # To work with TimingAndEstimationPlugin for percent complete, define ticket fields to use as the data source for:\n'
	[line 235]: '  fields.estimate = estimatedhours\n'
	[line 236]: '  fields.worked = totalhours\n'
	[line 238]: '  # Each unit in estimate is 1/8 of a day\n'
	[line 239]: '  days_per_estimate = 0.125\n'
	[line 241]: '  # To work with MasterTicketsPlugin for dependencies, define ticket fields to use as the data source for predecessor (pred) and successor (succ).\n'
	[line 242]: '  fields.pred = blockedby\n'
	[line 243]: '  fields.succ = blocking\n'
	[line 245]: '  # Alternatively, configure a pred-succ relation like:\n'
	[line 246]: '  #    relation.pred-succ = mastertickets,source,dest\n'
	[line 247]: '  # This causes TracPM to query the mastertickets table rather than\n'
	[line 248]: '  # parse blockedby and blocking custom fields.  This can be somewhat\n'
	[line 249]: '  # faster.\n'
	[line 252]: '  # To work with SubticketsPlugin for parent/child relationships, \n'
	[line 253]: '  # Ticket field to use as the data source for the parent \n'
	[line 254]: '  fields.parent = parents\n'
	[line 256]: '  # Alternatively, configure a parent-child relation like:\n'
	[line 257]: '  #    relation.parent-child = subtickets,parent,child\n'
	[line 258]: '  # This causes TracPM to query the subtickets table rather than parse \n'
	[line 259]: '  # the `parents` custom field.  This can be somewhat faster.\n'
	[line 260]: '  # When using SubticketsPlugin via a parent-child relation, do not \n'
	[line 261]: '  # configure a parent_format (next).\n'
	[line 264]: "  # To work with ChildTickets plugin parent_format, '#%s',\n"
	[line 265]: '  # Format of ticket IDs in parent field (default: %s).\n'
	[line 266]: '  parent_format = %s\n'
	[line 268]: '  # Custom fields for start and due dates\n'
	[line 269]: '  # Ticket field to use as the data source for start date (default: None)\n'
	[line 270]: '  fields.start = userstart\n'
	[line 271]: '  # Ticket field to use as the data source for finish date (default: None)\n'
	[line 272]: '  fields.finish = userfinish\n'
	[line 274]: "  # Format for ''start'' and ''finish'' date strings (default: '%Y-%m-%d')\n"
	[line 275]: '  date_format = %Y-%m-%d\n'
	[line 277]: "  # Ticket type for milestone-like tickets (default: 'milestone')\n"
	[line 278]: '  # Used to be milestone_type, that setting is now deprecated.\n'
	[line 279]: '  goal_ticket_type = milestone\n'
	[line 281]: '  # Ticket field to use as the data source for the percent complete column (default: None).\n'
	[line 282]: '  fields.percent = complete\n'
	[line 284]: '  # Hours represented by each unit of estimated work (default: 1).\n'
	[line 285]: '  hours_per_estimate = 1\n'
	[line 287]: '  # Default work for an unestimated task, same units as estimate  (default: 4.0).\n'
	[line 288]: '  default_estimate = 4.0\n'
	[line 290]: '  # How much work may be remaining when a task goes over estimate, same units as estimate (default: 0.0)..\n'
	[line 291]: '  estimate_pad = 0.0\n'
	[line 294]: '  option.formats = day|week|month|quarter\n'
	[line 295]: '  option.format = month\n'
	[line 296]: "  ## How and which 'columns' to show\n"
	[line 297]: '  option.lwidth = 300\n'
	[line 298]: '  option.res = 0\n'
	[line 299]: '  option.dur = 0\n'
	[line 300]: '  option.comp = 0\n'
	[line 301]: '  option.startDate = 0\n'
	[line 302]: '  option.endDate = 1\n'
	[line 303]: '  option.dateDisplay = yyyy-mm-dd\n'
	[line 304]: '  ## How and what to show on Gantt graph\n'
	[line 305]: '  option.showdep = 1\n'
	[line 306]: '  option.expandClosedTickets = 1\n'
	[line 307]: '  option.schedule = asap\n'
	[line 308]: '  option.openLevel = 0\n'
	[line 309]: '  option.colorBy = priority\n'
	[line 310]: '  option.userMap = 0\n'
	[line 311]: '  option.omitMilestone = 0\n'
	[line 312]: '  option.caption = Resource\n'
	[line 313]: '  option.hoursPerDay = 8.0\n'

Installation manual I got from http://trac-hacks.org/wiki/TracJsGanttPlugin.

I can't understand what's wrong and I hope that somebody can explain it to me.

Attachments (0)

Change History (7)

comment:1 Changed 7 months ago by tsmelyanskiy@…

I deleted everything from trac.ini and Trac began work correctly, but I got "ProgrammingError: You cannot execute SELECT statements in executemany()." Every time then I'm trying modify ticket. But the Trac accepts my changes.

comment:2 Changed 7 months ago by jun66j5

  • Description modified (diff)

comment:3 Changed 7 months ago by jun66j5

  • Keywords Trac jsGantt plugin TracjsGanttplugin removed

comment:4 Changed 7 months ago by rjollos

  • Resolution set to worksforme
  • Status changed from new to closed

The issue from comment:description is due to copy and pasting the configuration on the TracJsGanttPlugin wiki page, which had leading whitespace that ConfigParser doesn't like. The configuration on the wiki page has been corrected to remove the leading whitespace.

The issue from comment:1 is a duplicate of #11385.

Last edited 7 months ago by rjollos (previous) (diff)

comment:5 Changed 6 months ago by tsmelyanskiy@…

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Solution in #11385 doesn't help... I still have the problem

Trac detected an internal error:
ProgrammingError: You cannot execute SELECT statements in executemany().
Python Traceback

Most recent call last:
File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 497, in _dispatch_request
  dispatcher.dispatch(req)
File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 214, in dispatch
  resp = chosen_handler.process_request(req)
File "build/bdist.linux-x86_64/egg/trac/ticket/web_ui.py", line 179, in process_request
  return self._process_ticket_request(req)
File "build/bdist.linux-x86_64/egg/trac/ticket/web_ui.py", line 614, in _process_ticket_request
  self._do_save(req, ticket, action)
File "build/bdist.linux-x86_64/egg/trac/ticket/web_ui.py", line 1328, in _do_save
  replyto=req.args.get('replyto'))
File "build/bdist.linux-x86_64/egg/trac/ticket/model.py", line 365, in save_changes
  listener.ticket_changed(self, comment, author, old_values)
File "build/bdist.linux-x86_64/egg/tracjsgantt/tracpm.py", line 2963, in ticket_changed
  self.rescheduleTickets(ticket, old_values)
File "build/bdist.linux-x86_64/egg/tracjsgantt/tracpm.py", line 2751, in rescheduleTickets
  ids = self._findAffected(ticket, old_values)
File "build/bdist.linux-x86_64/egg/tracjsgantt/tracpm.py", line 2453, in _findAffected
  toExplore = more(border)
File "build/bdist.linux-x86_64/egg/tracjsgantt/tracpm.py", line 2412, in more
  newOwners = ownersOf(n)
File "build/bdist.linux-x86_64/egg/tracjsgantt/tracpm.py", line 2326, in ownersOf
  cursor.executemany(query, values)
File "build/bdist.linux-x86_64/egg/trac/db/util.py", line 85, in executemany
  return self.cursor.executemany(sql_escape_percent(sql), args)
File "build/bdist.linux-x86_64/egg/trac/db/sqlite_backend.py", line 62, in executemany
  args)
File "build/bdist.linux-x86_64/egg/trac/db/sqlite_backend.py", line 48, in _rollback_on_error
  return function(self, *args, **kwargs)


comment:6 Changed 6 months ago by jun66j5

  • Resolution set to worksforme
  • Status changed from reopened to closed

Please report to #11385 about the ProgrammingError problem.

comment:7 Changed 5 months ago by ChrisNelson

Please try the latest version. The ProgrammingError should be addressed.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.