Modify

Opened 7 months ago

Closed 7 months ago

#11663 closed defect (duplicate)

Some tables fail to copy in switch from MySQL to PostgreSQL

Reported by: Quince Owned by: robguttman
Priority: high Component: CodeReviewerPlugin
Severity: major Keywords:
Cc: Trac Release: 1.0

Description (last modified by rjollos)

The codereviewer table of CodeReviewerPlugin doesn't get copied. While this error has to do with that plugin, I'm posting it here because the command that fails is part of this plugin.

fatt:/tmp/m # ./trac-migrate.py --in-place /srv/trac postgres://tracuser:xxxxxxxxxx@127.0.0.1/trac?schema=trac`
Copying tables:
  attachment table... 37 records.
  auth_cookie table... 4 records.
  cache table... 8 records.
  codereviewer table... Traceback (most recent call last):
  File "./trac-migrate.py", line 55, in <module>
    sys.exit(main(sys.argv[1:]) or 0)
  File "./trac-migrate.py", line 51, in main
    return TracMigrationCommand(env)._do_migrate(dest, dburi)
  File "/tmp/m/tracmigrate/admin.py", line 29, in _do_migrate
    return self._do_migrate_inplace(dburi)
  File "/tmp/m/tracmigrate/admin.py", line 63, in _do_migrate_inplace
    self._copy_tables(src_db, dst_db, src_dburi, dburi, inplace=True)
  File "/tmp/m/tracmigrate/admin.py", line 108, in _copy_tables
    @self._with_transaction(dst_db)
  File "/tmp/m/tracmigrate/admin.py", line 197, in wrapper
    fn(db)
  File "/tmp/m/tracmigrate/admin.py", line 143, in copy
    cursor.executemany(query, rows)
  File "/usr/lib/python2.7/site-packages/trac/db/util.py", line 85, in executemany
    return self.cursor.executemany(sql_escape_percent(sql), args)
psycopg2.DataError: integer out of range

Attachments (0)

Change History (4)

comment:1 Changed 7 months ago by rjollos

  • Description modified (diff)

comment:2 Changed 7 months ago by Quince

  • Trac Release set to 1.0

comment:3 Changed 7 months ago by jun66j5

  • Component changed from TracMigratePlugin to CodeReviewerPlugin
  • Owner changed from jun66j5 to robguttman

That's a CodeReviewerPlugin issue that it doesn't support PostgreSQL. Also, a duplicate of #11664. Please don't multi-posting.

Last edited 7 months ago by jun66j5 (previous) (diff)

comment:4 Changed 7 months ago by jun66j5

  • Resolution set to duplicate
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.