Modify

Opened 4 months ago

Closed 4 months ago

#11685 closed defect (duplicate)

TypeError: 'NoneType' object is not iterable

Reported by: admin Owned by:
Priority: normal Component: TicketExtPlugin
Severity: normal Keywords:
Cc: Trac Release:

Description

How to Reproduce

While doing a GET operation on /admin/ticket/template_admin, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'cat_id': u'ticket', 'panel_id': u'template_admin', 'path_info': None}

User agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/33.0.1750.154 Safari/537.36

System Information

Trac 1.0.1
Babel 0.9.6
Genshi 0.6 (without speedups)
mod_wsgi 3.5 (WSGIProcessGroup WSGIApplicationGroup %{GLOBAL})
pysqlite 2.6.3
Python 2.7.5 (default, May 15 2013, 22:43:36) [MSC v.1500 32 bit (Intel)]
setuptools 3.4.3
SQLite 3.7.6.2
Subversion 1.8.3 (r1516576)
jQuery 1.7.2

Enabled Plugins

autocompleteusers 0.4.2dev
gridmodify 0.1.6dev
ticketextplugin 0.3.2
trac-jsgantt 0.10
tracaccountmanager 0.3.2
traccustomfieldadmin 0.2.8
tracdatefield 3.0.0dev
tracganttcalendarplugin 0.6.2-r843
tracmastertickets 3.0.4
tracpermredirect 2.0

Python Traceback

Traceback (most recent call last):
  File "build\bdist.win32\egg\trac\web\main.py", line 497, in _dispatch_request
    dispatcher.dispatch(req)
  File "build\bdist.win32\egg\trac\web\main.py", line 214, in dispatch
    resp = chosen_handler.process_request(req)
  File "build\bdist.win32\egg\trac\admin\web_ui.py", line 125, in process_request
    path_info)
  File "build\bdist.win32\egg\ticketext\template_admin.py", line 67, in render_admin_panel
    self._process_read(req, page_param)
  File "build\bdist.win32\egg\ticketext\template_admin.py", line 91, in _process_read
    for cf in customfields:
TypeError: 'NoneType' object is not iterable

Attachments (0)

Change History (1)

comment:1 Changed 4 months ago by jun66j5

  • Component changed from SELECT A HACK to TicketExtPlugin
  • Resolution set to duplicate
  • Status changed from new to closed

A duplicate of #8809.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from (none). Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.