Modify

Opened 7 years ago

Closed 7 years ago

#1254 closed defect (duplicate)

delete button not shown in ticket with 1.1.4 version of ticketdeleteplugin

Reported by: phpxcache@… Owned by: ashwin_phatak
Priority: normal Component: BatchModifyPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.10

Description

good version: r1346 (1.1) and bad version r2049 (1.1.4)

the 'delete' button used to shown with 'reply' button, but not with r2049.

Attachments (0)

Change History (4)

comment:1 Changed 7 years ago by phpxcache@…

  • Resolution set to invalid
  • Status changed from new to closed

the report is wrong. i'll reopen this ticket when i find the right reproducable way.

comment:2 Changed 7 years ago by phpxcache@…

  • Component changed from TicketDeletePlugin to BatchModifyPlugin
  • Resolution invalid deleted
  • Status changed from closed to reopened

Last Changed Rev: 1379

Index: batchmod/web_ui.py
===================================================================
--- batchmod/web_ui.py	(revision 2049)
+++ batchmod/web_ui.py	(working copy)
@@ -54,6 +54,8 @@
 
 
     # ITemplateProvider methods
+    def get_htdocs_dirs(self):
+        return []
 
     def get_templates_dirs(self):
         from pkg_resources import resource_filename

when requesting to http://..../project/chrome/mastertickets/x.png, i get. unstalling(not disable) BatchModifyPlugin make it ticket delete button works, it batchmodify that makes delete button files (js, i guess) failed to load

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 387, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.4/site-packages/trac/web/chrome.py", line 225, in process_request
    for dir in [os.path.normpath(dir[1]) for dir
AttributeError: 'BatchModifyModule' object has no attribute 'get_htdocs_dirs'

comment:3 Changed 7 years ago by prasand

  • Owner changed from coderanger to ashwin_phatak
  • Status changed from reopened to new

Ticket creator corrected the component, but not the assigned user. Updated.

comment:4 Changed 7 years ago by coling

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1337 (now fixed)

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.