Modify

Opened 7 years ago

Closed 7 years ago

#1303 closed defect (invalid)

Error with Tags and Blog plugins installed: TypeError: dictionary key must be string in tracrpc/web_ui.py

Reported by: nixar Owned by: anonymous
Priority: normal Component: EclipseTracPlugin
Severity: normal Keywords: eclipse rpc xmlrpc
Cc: Trac Release: 0.10

Description

# grep handler conf/trac.ini
default_handler = TagsWikiModule

2007-03-11 20:02:18,068 Trac[web_ui] ERROR: dictionary key must be string
2007-03-11 20:02:18,070 Trac[web_ui] ERROR: Traceback (most recent call last):
  File "/usr/lib/python2.3/site-packages/TracXMLRPC-0.1-py2.3.egg/tracrpc/web_ui.py", line 58, in process_request
    self._send_response(req, xmlrpclib.dumps(result, methodresponse=True))
  File "/usr/lib64/python2.3/xmlrpclib.py", line 961, in dumps
    data = m.dumps(params)
  File "/usr/lib64/python2.3/xmlrpclib.py", line 604, in dumps
    dump(v, write)
  File "/usr/lib64/python2.3/xmlrpclib.py", line 616, in __dump
    f(self, value, write)
  File "/usr/lib64/python2.3/xmlrpclib.py", line 692, in dump_struct
    raise TypeError, "dictionary key must be string"
TypeError: dictionary key must be string

Attachments (0)

Change History (2)

comment:1 Changed 7 years ago by anonymous

  • Owner changed from merlimat to anonymous
  • Status changed from new to assigned

Cannot reproduce the error. I've installed the Tags plugin and everything is working fine..
Can someone confirm this error?

comment:2 Changed 7 years ago by merlimat

  • Resolution set to invalid
  • Status changed from assigned to closed

Cannot reproduce it with latest version of all plugins.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from anonymous. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.