Modify

Opened 7 years ago

Closed 7 years ago

#1398 closed defect (duplicate)

r2128, 0.10, crashes on login (?)

Reported by: dr2chase@… Owned by: mgood
Priority: normal Component: AccountManagerPlugin
Severity: major Keywords:
Cc: Trac Release: 0.10

Description

I do not know enough Python to be certain of this, but it looks suspect.
Attempting to log in yields a page ending like so:

Traceback (most recent call last):
  File "/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/site-packages/trac/web/main.py", line 387, in dispatch_request
    dispatcher.dispatch(req)
  File "/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/site-packages/trac/web/main.py", line 182, in dispatch
    req.authname = self.authenticate(req)
  File "/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/site-packages/trac/web/main.py", line 146, in authenticate
    authname = authenticator.authenticate(req)
  File "build/bdist.darwin-8.9.0-Power_Macintosh/egg/acct_mgr/web_ui.py", line 334, in wrap
  File "build/bdist.darwin-8.9.0-Power_Macintosh/egg/acct_mgr/web_ui.py", line 344, in authenticate
  File "build/bdist.darwin-8.9.0-Power_Macintosh/egg/acct_mgr/web_ui.py", line 371, in _remote_user
  File "build/bdist.darwin-8.9.0-Power_Macintosh/egg/acct_mgr/api.py", line 104, in check_password
  File "build/bdist.darwin-8.9.0-Power_Macintosh/egg/acct_mgr/htfile.py", line 72, in check_password
  File "build/bdist.darwin-8.9.0-Power_Macintosh/egg/acct_mgr/htfile.py", line 176, in _check_userline
NameError: global name 'user' is not defined}}}

The relevant code reads
{{{
    def _check_userline(self, password, prefix, suffix):
        return suffix == htdigest(user, self.realm, password)
}}}
Most of the other code in {{{htfile.py}}} passes or gets {{{user}}} as a parameter, so it seems likely that was omitted here.

I just installed this egg (globally) to replace an earlier version (I am about to attempt further customization, but thought that it would be prudent to see if it worked before I touched it).  I also removed a customized {{{login.cs}}} in case that was the problem.

Attachments (0)

Change History (1)

comment:1 Changed 7 years ago by mgood

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #1392.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.