Modify

Opened 8 years ago

Closed 8 years ago

#1476 closed defect (fixed)

Reports Not Working (No Handler Matched)

Reported by: oliver.thylmann@… Owned by: bobbysmith007
Priority: normal Component: TimingAndEstimationPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.10

Description

Installation of the plugin went fine. Upgrade went through without errors. The time fields in the tasks are there. The Management menu item is there.

The thing that doesn't work is the reports. I get an error like this:

No handler matched request to /report/9

Here is the url: http://trac.somewhere/report/9?BILLABLE=1&UNBILLABLE=1&NEW=new&ASSIGNED=assigned&REOPENED=reopened&CLOSED=closed&STARTDATE=0&ENDDATE=2000000000

The install was done with: clearsilver-0.10.3-3.fc4 python-clearsilver-0.10.3-3.fc4 trac 0.10

To make sure that it's not a trac problem, I then upgraded trac to 0.10.4 this morning and upgraded again (only the trac upgrade obviously) and it is still not working.

If you need further information please tell me.

Attachments (0)

Change History (7)

comment:1 Changed 8 years ago by bobbysmith007

Do you have the WebAdmin Plugin Installed?

  • If so can you please ensure that all components are enabled
  • if not check your trac.ini file for:
    [components]
    timingandestimationplugin.* = enabled
    

if something was not enabled, enable it then re-run

trac-admin [trac-instance] upgrade

If this is not the problem or does not fix it we need to determine which of the following is the case.

  • there is a problem with the mapping between the Management Page and the reports
  • the reports did not get properly installed.

Also:

  • What database backend are your running?
  • Do the other trac reports still work ?

Hopefully this will allow us to diagnose and treat the problem,

Russ

comment:2 Changed 8 years ago by oliver.thylmann@…

hi,

this already in there:

[components] timingandestimationplugin.* = enabled trac.ticket.report.* = disabled webadmin.* = enabled mastertickets.* = enabled burndown.* = enabled

just so you have all of them.

Database is: trac.db: SQLite database (Version 3)

The other reports still work, the ones under /query you mean I presume. I can also add the fields for estimate and work performed and see those there.

comment:3 Changed 8 years ago by bobbysmith007

The following line should not appear in your components section.

trac.ticket.report.* = disabled

That is turning off reports. If that is disabled due to one of the other plugins that have been installed, I am not sure what to tell you. I have not been notified that this plugin conflicted with others, but it would not be the most surprising thing in the world either.

Hope this gets you running, let me know how it goes.

comment:4 Changed 8 years ago by bobbysmith007

  • Resolution set to fixed
  • Status changed from new to closed

also feel free to reopen if this doesn't solve your problem

comment:5 Changed 8 years ago by oliver.thylmann@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

ok cool, that worked. The disabled flag was for disabling the old reports in 0.10 by the way. Does not seem to be needed anymore in 0.10.4 which uses the new reports by default.

The problem is that I still have problems. But we are one step further! :)

now I get this:

Report execution failed: near "as": syntax error

http://somewhere.com/report/16?BILLABLE=0&UNBILLABLE=0&NEW=new&ASSIGNED=assigned&REOPENED=reopened&CLOSED=&STARTDATE=0&ENDDATE=2000000000

That's with every report. I put in # in front of the line in question and restarted apache just to be sure.

comment:6 Changed 8 years ago by bobbysmith007

see if this helps: #1480 he claims that some versions of sqlite over the required version still have the same problem. and lists some versions that fixed the problem for him.

Hopefully this will help. Please let me know if this fixes it for you.

comment:7 Changed 8 years ago by oliver.thylmann@…

  • Resolution set to fixed
  • Status changed from reopened to closed

We updated to sqlite-3.3.17.so and it's working. Thanks a lot.

Add Comment

Modify Ticket

Action
as closed The owner will remain bobbysmith007.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.