Modify

Opened 7 years ago

Closed 7 years ago

#1498 closed defect (duplicate)

TracPygmentsPlugin - dont work on 0.10.3

Reported by: anonymous Owned by: mgood
Priority: high Component: TracPygmentsPlugin
Severity: major Keywords:
Cc: Trac Release: 0.10

Description

Can any one fix it ?

This is few lines from log.

2007-04-30 11:15:49,339 Trac[browser] DEBUG: Rendering preview of node main_dll.cpp@None with mime-type text/x-c++src; charset=iso-8859-15
2007-04-30 11:15:49,389 Trac[api] DEBUG: Trying to render HTML preview using PygmentsRenderer
2007-04-30 11:15:49,395 Trac[api] WARNING: HTML preview using <tracpygments.PygmentsRenderer object at 0xb7b4e0cc> failed ('module' object has no attribute 'get_lexer_by_name
')
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/trac/mimeview/api.py", line 448, in render
    filename, url)
  File "build/bdist.linux-x86_64/egg/tracpygments/__init__.py", line 77, in render
  File "build/bdist.linux-x86_64/egg/tracpygments/__init__.py", line 112, in _format
AttributeError: 'module' object has no attribute 'get_lexer_by_name'

Attachments (0)

Change History (2)

comment:1 Changed 7 years ago by anonymous

Did you upgrade your projet ?

trac-admin <project_path> upgrade

Pygments works for me (0.10.3)

comment:2 Changed 7 years ago by mgood

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #1078 which has already been fixed. You'll need to update your plugin.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from mgood. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.