Modify

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#1570 closed defect (wontfix)

Permission doesn't show up under -0.11dev

Reported by: bewst Owned by: Chriki
Priority: normal Component: RestrictedAreaPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

Using the development version of Trac, RESTRICTED_AREA_ACCESS doesn't show up among the permissions in the account manager plugin, and even unauthenticated users seem to be able to look at my wiki/restricted page. Is there anything I can do about this?

Thanks very much in advance, Dave

Attachments (0)

Change History (6)

comment:1 follow-up: Changed 7 years ago by anonymous

This is also the case for trac 0.10.4!

comment:2 in reply to: ↑ description Changed 7 years ago by Chriki

  • Resolution set to wontfix
  • Status changed from new to closed
  • Summary changed from Permission doesn't show up under -0.11dev to Support only for current stable version 0.10.x

Hi Dave,

thanks for your interest in the RestrictedAreaPlugin.

Replying to bewst:

Using the development version of Trac, RESTRICTED_AREA_ACCESS doesn't show up among the permissions in the account manager plugin, and even unauthenticated users seem to be able to look at my wiki/restricted page. Is there anything I can do about this?

I'm sorry, but as stated on the plugin's wiki page, I can only support the current stable Trac version 0.10.x. Anyone who'd like to port the plugin to 0.11 is welcome to submit a patch, though.

Cheers,
Chriki

comment:3 Changed 7 years ago by Chriki

  • Summary changed from Support only for current stable version 0.10.x to Permission doesn't show up under -0.11dev

(oops, mistaken the ticket summary with a comment summary – reverted to original text)

comment:4 in reply to: ↑ 1 Changed 7 years ago by Chriki

Hello,

thanks for your report.

Replying to anonymous:

This is also the case for trac 0.10.4!

Unfortunately I can't reproduce this. For me the plugin works flawlessly in Trac 0.10.4. Please open a new ticket if you have more specific information on the issue.

Cheers,
Chriki

comment:5 follow-up: Changed 7 years ago by coderanger

It is worth noting that thanks to Alec's security work being merged in 0.11dev, this would be a ~10 line plugin now.

comment:6 in reply to: ↑ 5 Changed 7 years ago by Chriki

Hi coderanger!

Replying to coderanger:

It is worth noting that thanks to Alec's security work being merged in 0.11dev, this would be a ~10 line plugin now.

Thanks for pointing this out. I think I'll then have a look at porting the plugin to 0.11 when the new Trac version is stable.

Cheers,
Chriki

Add Comment

Modify Ticket

Action
as closed The owner will remain Chriki.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.