Modify

Opened 8 years ago

Closed 7 years ago

Last modified 6 months ago

#1588 closed enhancement (fixed)

Modify/edit comments in tickets

Reported by: maxim Owned by: anybody
Priority: highest Component: Request-a-Hack
Severity: normal Keywords: comment ticket
Cc: slestak989@… Trac Release: 0.10

Description

Once a comment is added to a ticket, it can't be modified.

Of course the "preview" button is meant to try to avoid this case, though it would be useful in some situations.

This plugin would add a "edit" button to each comment. Only the owner of the comment (and possibly an administrator ?) would be able to modify it.

Attachments (0)

Change History (11)

comment:1 Changed 8 years ago by maxim

  • Priority changed from normal to high

comment:2 Changed 8 years ago by luchko@…

  • Priority changed from high to highest

I would also vote for this enhancement.

comment:3 Changed 8 years ago by Daniel Werner <dan@…>

I was also looking for such a plugin ! It would be very much appreciated

comment:4 follow-up: Changed 8 years ago by anonymous

I was also vote for this.

comment:5 Changed 8 years ago by maxim

Hmm I guess the best way to vote for this request is actually to register (http://www.trac-hacks.org/register), to login, then to go on http://www.trac-hacks.org/wiki/RequestaHack to save the vote

(I say this because, for now, I am now the only voter!)

comment:6 in reply to: ↑ 4 Changed 7 years ago by anonymous

Replying to anonymous:

I was also vote for this.

Plus one vote for me too!

comment:7 Changed 7 years ago by anonymous

another vote here!

comment:8 Changed 7 years ago by anonymous

Plus one!

comment:9 Changed 7 years ago by anonymous

This will indeed be useful. Lots of testers do not know about WikiFormatting and we end up with hard to read comments in tickets which cannot be modified.

comment:10 Changed 7 years ago by slestak

  • Cc slestak989@… added; anonymous removed

Is 2040 a dupe of this?

comment:11 Changed 7 years ago by SergeiLuchko

  • Resolution set to fixed
  • Status changed from new to closed

Checkout TicketChangePlugin. It adds Change button next to the Reply of the ticket comment.

Currently only administrator can change the ticket comments (editing by owner is not supported for now). The users who have no TICKET_ADMIN permissions will not see the Change button.

Add Comment

Modify Ticket

Action
as closed The owner will remain anybody.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.