Modify

Opened 7 years ago

Closed 7 years ago

#1608 closed defect (worksforme)

Eclipse error when opening a wiki page

Reported by: remy.blank@… Owned by: merlimat
Priority: normal Component: EclipseTracPlugin
Severity: major Keywords:
Cc: Trac Release: 0.10

Description

I installed EclipseTracPlugin on Eclipse 3.2.1 on Linux. Trac version is 0.10.3.1.

Most of the time, when I open a wiki page for editing, I get the following Eclipse error dialog:

Error creating nested text editor
Editor could not be initialized

And the details:

java.lang.reflect.UndeclaredThrowableException

When I click OK, I get an empty preview view, but there is no "source" tab at the bottom of the view.

However, sometimes, the editor opens just fine, and I can edit the wiki page and see the preview.

Attachments (2)

success.dump (13.6 KB) - added by remy.blank@… 7 years ago.
tcpdump of a successful wiki page open in Eclipse
failure.dump (14.8 KB) - added by remy.blank@… 7 years ago.
tcpdump of a failed wiki page open in Eclipse

Download all attachments as: .zip

Change History (8)

comment:1 Changed 7 years ago by merlimat

  • Severity changed from normal to major
  • Status changed from new to assigned

Ok, I can reproduce the error: it happens every time you are "connected" status with a trac server, but the server is unreachable when you try to open the page.

The error message should be more clear in this case and perhaps it worts to periodically check the servers heartbeat.

Anyway the editor view should not even open.

If your error does not fall under this case, can you please send me a tcpdump/wireshark capture log of the communication between eclipse and web server?

comment:2 Changed 7 years ago by remy.blank@…

You're right, I get the following message in my trac log every time opening an editor fails:

2007-06-04 17:41:28,375 Trac[main] WARNING: 404 Not Found (No handler matched request to /login/xmlrpc)

In my apache error log, I get two such lines for every successful open, but only one when opening fails (I'm using digest authentication):

[Mon Jun 04 17:44:08 2007] [error] [client 172.16.30.14] Digest: client used wrong authentication scheme `Basic': /dev/login/xmlrpc
[Mon Jun 04 17:44:08 2007] [error] [client 172.16.30.14] Digest: client used wrong authentication scheme `Basic': /dev/login/xmlrpc

My server is on the same ethernet segment and is always reachable (at least it works with a browser), so it shouldn't be a connectivity problem.

I'll generate a tcpdump capture of both successful and failed transactions.

Changed 7 years ago by remy.blank@…

tcpdump of a successful wiki page open in Eclipse

Changed 7 years ago by remy.blank@…

tcpdump of a failed wiki page open in Eclipse

comment:3 Changed 7 years ago by remy.blank@…

I attached dumps for both a successful and a failed wiki page open in Eclipse. In the failed case, two things seem strange:

  • The plugin always tries basic authentication first, and only digest auth after the error response. You might want to add a configuration check box for digest auth so that this initial request is not necessary. But this is only a performance improvement.
  • The error is a 404 Not Found, with Trac reporting "No handler matched request to /login/xmlrpc". This might not be a problem in EclipseTracPlugin, but in TracXMLRPC.

In case this helps, I'm running apache-2.0.58 and mod_python-3.2.10. Let me know if you need anything else.

comment:4 Changed 7 years ago by remy.blank@…

Ok, it looks like I'm the one to blame. I had only just installed the trac plugins (TracXMLRPC and EclipseTracPlugin). Since they had appeared on the plugins page of webadmin, I had wrongly assumed that plugins are activated "live", without needing an apache restart. What probably happens is that currently running worker processes don't have the plugins, whereas newly created ones have. This explains why it worked some of the time.

I have restarted apache and now everything works well. So I guess this issue can mutate from a "defect" to an "enhancement" request for slightly more verbose error messages, possibly also displaying the error from trac (i.e. the "no handler for..." message above).

Other than that, thanks for a great plugin!

comment:5 Changed 7 years ago by merlimat

Thank you for the analysis..

I'm now looking to change the HTTP backend used by the apache xmlrpc library, to have more insights of the possible connections errors (cannot connect to server, cannot authenticate, 404, etc.. )

comment:6 Changed 7 years ago by merlimat

  • Resolution set to worksforme
  • Status changed from assigned to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.