Modify

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#1638 closed defect (duplicate)

assertion on trying to look at the tree

Reported by: anonymous Owned by: eblot
Priority: normal Component: RevtreePlugin
Severity: critical Keywords:
Cc: Trac Release: 0.10

Description

I get the following backtrace when trying to look at the revtree.
FYI: the mentioned revision deletes a few files in /branches/servers/* and at the same time copies some files from /branches/servers to /tags/servers.

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 406, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "build/bdist.linux-x86_64/egg/revtree/web_ui.py", line 186, in process_request
  File "build/bdist.linux-x86_64/egg/revtree/web_ui.py", line 314, in _process_revtree
  File "build/bdist.linux-x86_64/egg/revtree/model.py", line 309, in build
  File "build/bdist.linux-x86_64/egg/revtree/model.py", line 58, in build
AssertionError: Incoherent path [tags] != [branches/servers] rev: 44826

Attachments (0)

Change History (2)

comment:1 Changed 7 years ago by eblot

  • Resolution set to duplicate
  • Severity changed from blocker to critical
  • Status changed from new to closed

comment:2 Changed 7 years ago by eblot

Acually, this is a duplicate of #1284, but ticket:1090:2 provides the details about this very issue.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from eblot. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.