Modify

Opened 8 years ago

Closed 7 years ago

#1661 closed defect (duplicate)

RuntimeError: maximum recursion depth exceeded

Reported by: Stefan.Galinski@… Owned by: coderanger
Priority: high Component: TracForgePlugin
Severity: blocker Keywords: maximum recursion depth exceeded
Cc: Trac Release: 0.10

Description

I have got the error message if i click on any link in the project index (all /projects/<env> links). I havent found any hint to fix the problem, but some small url rewrites can do the job also.

The next part of the report describes the rewrite workaround.

File: your specific trac configuration file of the webserver

Content: (Only the necessary parts for the workaround)

####
    RewriteEngine on

    RedirectMatch ^/mainEnv$ http://taco11.taco.frm2:8000/
    RedirectMatch ^/projects/env1$ http://taco11.taco.frm2:8000/env1
    RedirectMatch ^/projects/env2$ http://taco11.taco.frm2:8000/env2

    <Location />
        SetHandler mod_python
        PythonHandler trac.web.modpython_frontend
        PythonOption TracEnv /var/lib/trac/mainEnv
        PythonOption TracUriRoot /
        SetEnv PYTHON_EGG_CACHE /usr/share/trac/egg_cache
    </Location>

    <LocationMatch /(env1|env2)>
        PythonOption TracEnv ""
        PythonOption TracEnvParentDir /var/lib/trac
    </LocationMatch>
####

Attachments (0)

Change History (2)

comment:1 Changed 7 years ago by mpalmer@…

Stefan,

I think I've come across the same ultimate problem as you, with a different end-result. In my case, I don't get a recursion depth error, but I do get an error page. I've documented my results and given a patch in #1880; perhaps you'd like to apply it and see where it gets you?

comment:2 Changed 7 years ago by Stefan.Galinski@…

  • Resolution set to duplicate
  • Status changed from new to closed

Hi,

Your patch works like a charm. Nice work!

I will mark the patch as duplicate of #1880.

Add Comment

Modify Ticket

Action
as closed The owner will remain coderanger.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.