Modify

Opened 7 years ago

Closed 4 years ago

#1692 closed defect (wontfix)

No 'envroot' set in global trac.ini

Reported by: gustavo@… Owned by: brad
Priority: high Component: DbAuthPlugin
Severity: blocker Keywords:
Cc: Trac Release: 0.10

Description

Hello.

I've installed DbAuthPlugin for Trac 0.10.4 and everytime I access the login page I get this:

Traceback (most recent call last):
  File "/home/glm_trac/packages/lib/python2.3/site-packages/trac/web/main.py", line 406, in dispatch_request
    dispatcher.dispatch(req)
  File "/home/glm_trac/packages/lib/python2.3/site-packages/trac/web/main.py", line 173, in dispatch
    for handler in self.handlers:
  File "/home/glm_trac/packages/lib/python2.3/site-packages/trac/core.py", line 55, in extensions
    return filter(None, [component.compmgr[cls] for cls in extensions])
  File "/home/glm_trac/packages/lib/python2.3/site-packages/trac/core.py", line 179, in __getitem__
    component = cls(self)
  File "/home/glm_trac/packages/lib/python2.3/site-packages/trac/core.py", line 98, in maybe_init
    init(self)
  File "build/bdist.linux-i686/egg/dbauth/auth.py", line 39, in __init__
  File "build/bdist.linux-i686/egg/dbauth/env.py", line 30, in get_envname
TracError: No 'envroot' set in global trac.ini

However, this is what I've added to my global Trac file:

[components]
trac.web.auth.* = disabled
dbauth.* = enabled
trac.userdir.* = enabled  # only if you want to use this

[central]
database = /home/glm_trac/trac_sites/dbauth.db
envroot = /home/glm_trac/trac_sites/glm

An my project configuration file contains this:

[inherit]
file = /home/glm_trac/packages/share/trac/conf/trac.ini

I've checked every single path and they're all fine.

Thanks in advance!

Attachments (1)

trac-dbauth-plugin-0.4-0.1.dev_r3881.fc9.src.rpm (9.0 KB) - added by anonymous 6 years ago.
simple 0.10 (0.4-dev_r3881) tested and worked on fedora 9

Download all attachments as: .zip

Change History (6)

comment:1 Changed 7 years ago by anonymous

  • Priority changed from normal to high
  • Severity changed from normal to blocker
  • Trac Release changed from 0.11 to 0.10

comment:2 Changed 7 years ago by Gustavo Narea

I've found the solution here: http://www.fuzzylizard.com/archives/2007/01/16/854/

Cheers.

Gustavo.

comment:3 Changed 7 years ago by brad

  • Resolution set to worksforme
  • Status changed from new to closed

As noted in the site where you found the solution, the tutorial http://natmaster.com/articles/installing_trac_0.10.php is wrong:

incorrect:

[central]
database = /home/glm_trac/trac_sites/dbauth.db

a database URL should always start with a scheme

correct:

[central]
database = sqlite:/home/glm_trac/trac_sites/dbauth.db

comment:4 Changed 7 years ago by aeron.chang@…

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I have followed the solution posted above but that didn't fix the problem. I added the following:

[central]
database = sqlite:/home/tracadmin/trac_sites/dbauth.db
envroot = /home/tracadmin/trac_sites/Brudden-E750

users_table = trac_users
users_envname_field = all
users_usersname_field = aeron
users_password_field = jimmie
users_email_field = aeron.chang@gmail.com

perms_table = trac_permissions
perms_envname_field = all
perms_usersname_field = aeron
perms_groupname_field = admins

Can anyone help me please?! I have exact same problem after following natmaster's guide on Trac 0.10.3. Where do i set up the project configuration file?

Changed 6 years ago by anonymous

simple 0.10 (0.4-dev_r3881) tested and worked on fedora 9

comment:5 Changed 4 years ago by rjollos

  • Resolution set to wontfix
  • Status changed from reopened to closed

Closing tickets for a deprecated plugin.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from brad. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.