Modify

Opened 7 years ago

Closed 7 years ago

#1725 closed defect (fixed)

Environment not found

Reported by: iparaian@… Owned by: coling
Priority: high Component: WorkLogPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.10

Description

When I press the "Work on this ticket now" button I get: "Environment not found"

Attachments (1)

trac.log (10.3 KB) - added by iparaian@… 7 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 follow-up: Changed 7 years ago by coling

Hmmm, interesting.

Can you say what version of Python/Trac you are using?

Can you view the (empty) Work Log page OK?

comment:2 in reply to: ↑ 1 Changed 7 years ago by iparaian@…

Python 2.44 Trac 0.10.3.1 Yes I can view the Work Log empty.

comment:3 Changed 7 years ago by coling

Hmmm. That's an odd one. I'll have to ask on #trac IRC as I don't really know how to fix that :(

Is there anything in the debug log that would be of any use? (turn on logging first ;))

Changed 7 years ago by iparaian@…

comment:4 Changed 7 years ago by iparaian@…

Any news?

comment:5 Changed 7 years ago by coling

Sorry I wasn't emailed about the fact you'd added the log :(

One thing is for certain, you are suffering from a bug in the BatchModifyPlugin

See #1684 for a debug and a link to the ticket that contains a patch for BatchModifyPlugin

I'm hoping that this will actually fix it, but can't be certain. If it does, please add a "Please apply this" to the relevant ticket as I'm not sure the original author is available and it's just making work difficult for other plugin authors :( (assuming that is the problem!)

comment:6 Changed 7 years ago by anonymous

I uninstalled BatchModifyPlugin and i still get the "Environment not found" message when I press the "Work on this ticket now".

comment:7 Changed 7 years ago by iparaian@…

Sorry, I didn't added my email to the comment.

comment:8 Changed 7 years ago by coling

Hehe, s'ok I would have guessed it was you without the email.

I'm a bit stumped to be honest.

I do notice you have the ScrumBurndownPlugin installed, so perhaps it is related to #1668 ?

What is also a little odd is that I fixed a bug that prevented (or so I thought) the "Work on this ticket now" button from being shown when you also have the TimingAndEstimationPlugin installed which you do. I only committed the fix last night so it's odd you even got the button! But then I'm only pointing out a bug you that don't suffer from so I should just shut up!!

Anyways, try the latest svn of WorkLogPlugin (not that I think it will help too much) and see if ScrumBurndownPlugin is getting in the way. If it isn't then perhaps this bug has the same root cause as #1668

comment:9 Changed 7 years ago by iparaian@…

ok, I uninstalled ScrumBurndownPlugin and i still get "Environment not found". You said "I fixed a bug that prevented (or so I thought) the "Work on this ticket now" button from being shown when you also have the TimingAndEstimationPlugin installed" But why? How WorkLogPlugin is supposed to work if you don't have the "Work on this ticket now" button? My "User Activity Last Change" list si empty.

comment:10 Changed 7 years ago by coling

Damn :(

I guess there is a more fundamental problem but without being able to reproduce it I'm a bit stumped :( FYI the URL that is displayed after clicking "Work on this Ticket now" button should be the same as that displayed when you just view the (empty) work log.

You are correct in that this button is currently the only way to make this plugin useful :) I will be adding an XMLRPC interface soon and also a Python GTK based desktop app to go with it, but that is another story. The fact that the button didn't show up was a bug pure and simple and I only noticed it last night when I actually installed T&E on my test Trac :D

I don't think I can be much help to sort this out. All I can suggest is to go through and put debug stuff in webui.py e.g. self.log.debug('xxxxx')

If the URL is different as mentioned above then this may explain it, but it shouldn't be any different. Do you use a MultiProject trac install? e.g. where the path in the URL points to different trac instances?

comment:11 Changed 7 years ago by iparaian@…

I have 2 projects in 2 directories repo - E:\Repository\trac\repo repo_cms - E:\Repository\trac\repo_cms that starts with the same tracd service with this command line: D:\Python244\Scripts\tracd.py -p8000 -a *,E:\Repository\passwd.htdigest,trac -e E:\Repository\trac

And here is the configuration of the project from .ini file.: [trac] authz_file = authz_module_name = base_url = http://server:8000/repo_cms/ check_auth_ip = true database = sqlite:db/trac.db default_charset = iso-8859-15 default_handler = WikiModule htdocs_location = ignore_auth_case = false mainnav = wiki,timeline,roadmap,browser,tickets,newticket,search metanav = login,logout,settings,help,about permission_store = DefaultPermissionStore repository_dir = E:\Repository\svn\repo_cms\ repository_type = svn request_filters = PageQueryModule timeout = 20

comment:12 Changed 7 years ago by coling

  • Resolution set to fixed
  • Status changed from new to closed

(In [2396]) Closes #1725. Fix a hard coded path to the worklog page. Apologies for this stupid error to iparaian (at) gmail (dot) com. Thanks for your patience.

Add Comment

Modify Ticket

Action
as closed The owner will remain coling.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.