Modify

Opened 7 years ago

Closed 7 years ago

#1787 closed defect (duplicate)

Getting assertion error after logging into master environment.

Reported by: searay268 Owned by: coderanger
Priority: normal Component: TracForgePlugin
Severity: normal Keywords:
Cc: Trac Release: 0.10

Description

Using apache 2.2.4 with Trac 0.10.4 using Fast CGI.

Python 2.5.

Every time I log into the master environment I am trying to setup, I get an assertion error.

2007-07-11 15:07:49,365 Trac[loader] DEBUG: Loading egg plugin webadmin.logging from /usr/lib/python2.5/site-packages/TracWebAdmin-0.1.2dev_r5753-py2.5.egg
2007-07-11 15:07:49,367 Trac[loader] DEBUG: Loading egg plugin webadmin.ticket from /usr/lib/python2.5/site-packages/TracWebAdmin-0.1.2dev_r5753-py2.5.egg
2007-07-11 15:07:49,369 Trac[loader] DEBUG: Loading egg plugin webadmin.basics from /usr/lib/python2.5/site-packages/TracWebAdmin-0.1.2dev_r5753-py2.5.egg
2007-07-11 15:07:49,371 Trac[loader] DEBUG: Loading egg plugin webadmin.perm from /usr/lib/python2.5/site-packages/TracWebAdmin-0.1.2dev_r5753-py2.5.egg
2007-07-11 15:07:49,372 Trac[loader] DEBUG: Loading egg plugin webadmin.web_ui from /usr/lib/python2.5/site-packages/TracWebAdmin-0.1.2dev_r5753-py2.5.egg
2007-07-11 15:07:49,373 Trac[loader] DEBUG: Loading egg plugin webadmin.plugin from /usr/lib/python2.5/site-packages/TracWebAdmin-0.1.2dev_r5753-py2.5.egg
2007-07-11 15:07:49,420 Trac[loader] DEBUG: Loading egg plugin tracforge.subscriptions from /usr/lib/python2.5/site-packages/TracForge-1.1-py2.5.egg
2007-07-11 15:07:49,433 Trac[loader] DEBUG: Loading egg plugin tracforge.admin from /usr/lib/python2.5/site-packages/TracForge-1.1-py2.5.egg
2007-07-11 15:07:49,441 Trac[loader] DEBUG: Loading egg plugin tracforge.resources from /usr/lib/python2.5/site-packages/TracForge-1.1-py2.5.egg
2007-07-11 15:07:49,443 Trac[loader] DEBUG: Loading egg plugin tracforge.linker from /usr/lib/python2.5/site-packages/TracForge-1.1-py2.5.egg
2007-07-11 15:07:49,452 Trac[loader] DEBUG: Loading egg plugin tracforge.perms from /usr/lib/python2.5/site-packages/TracForge-1.1-py2.5.egg
2007-07-11 15:07:49,468 Trac[loader] DEBUG: Loading egg plugin navadd from /usr/lib/python2.5/site-packages/NavAdd-0.1-py2.5.egg
2007-07-11 15:07:49,470 Trac[loader] DEBUG: Loading egg plugin codereview from /usr/lib/python2.5/site-packages/TracCodeReview-2.0dev-py2.5.egg
2007-07-11 15:07:49,486 Trac[loader] DEBUG: Loading egg plugin acct_mgr.admin from /usr/lib/python2.5/site-packages/TracAccountManager-0.1.3dev_r2171-py2.5.egg
2007-07-11 15:07:49,503 Trac[loader] DEBUG: Loading egg plugin acct_mgr.db from /usr/lib/python2.5/site-packages/TracAccountManager-0.1.3dev_r2171-py2.5.egg
2007-07-11 15:07:49,507 Trac[loader] DEBUG: Loading egg plugin acct_mgr.htfile from /usr/lib/python2.5/site-packages/TracAccountManager-0.1.3dev_r2171-py2.5.egg
2007-07-11 15:07:49,510 Trac[loader] DEBUG: Loading egg plugin acct_mgr.http from /usr/lib/python2.5/site-packages/TracAccountManager-0.1.3dev_r2171-py2.5.egg
2007-07-11 15:07:49,512 Trac[loader] DEBUG: Loading egg plugin acct_mgr.pwhash from /usr/lib/python2.5/site-packages/TracAccountManager-0.1.3dev_r2171-py2.5.egg
2007-07-11 15:07:49,513 Trac[loader] DEBUG: Loading egg plugin acct_mgr.web_ui from /usr/lib/python2.5/site-packages/TracAccountManager-0.1.3dev_r2171-py2.5.egg
2007-07-11 15:07:49,514 Trac[loader] DEBUG: Loading egg plugin acct_mgr.api from /usr/lib/python2.5/site-packages/TracAccountManager-0.1.3dev_r2171-py2.5.egg
2007-07-11 15:07:49,517 Trac[loader] DEBUG: Loading egg plugin ticketdelete.web_ui from /usr/lib/python2.5/site-packages/TracTicketDelete-1.1.4-py2.5.egg
2007-07-11 15:07:49,606 Trac[manager] DEBUG: SubscriptionManager: Found db version 1, current is 1
2007-07-11 15:07:49,606 Trac[api] DEBUG: TracforgeAdminSystem: Found db version 7, current is 7
2007-07-11 15:07:49,653 Trac[perm] DEBUG: TracForgeGroupModule: Detected master groups (anonymous) for anonymous
2007-07-11 15:07:59,166 Trac[perm] DEBUG: TracForgeGroupModule: Detected master groups (anonymous) for anonymous
2007-07-11 15:07:59,225 Trac[main] WARNING: 403 Forbidden (403 Forbidden (WIKI_VIEW privileges are required to perform this operation))
2007-07-11 15:08:01,457 Trac[perm] DEBUG: TracForgeGroupModule: Detected master groups (anonymous) for anonymous
2007-07-11 15:08:06,089 Trac[perm] DEBUG: TracForgeGroupModule: Detected master groups (anonymous, authenticated) for wlw
2007-07-11 15:08:06,233 Trac[auth] DEBUG: TracForgeCookieMunger: Got referer as u'http://robin/trac/RedEnvelope/'
2007-07-11 15:08:06,233 Trac[auth] DEBUG: TracForgeCookieMunger: parts=(u'http', u'robin', u'/trac/RedEnvelope/', '', '') name='robin'
2007-07-11 15:08:06,237 Trac[main] ERROR: Header values must be strings
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/trac/web/main.py", line 406, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.5/site-packages/trac/web/main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "build/bdist.linux-i686/egg/acct_mgr/web_ui.py", line 359, in process_request
    return auth.LoginModule.process_request(self, req)
  File "/usr/lib/python2.5/site-packages/trac/web/auth.py", line 103, in process_request
    self._redirect_back(req)
  File "build/bdist.linux-i686/egg/acct_mgr/web_ui.py", line 381, in _redirect_back
    req.redirect(referer or self.env.abs_href())
  File "/usr/lib/python2.5/site-packages/TracForge-1.1-py2.5.egg/tracforge/linker/auth.py", line 62, in my_redirect
    Request.redirect(req, referer)
  File "/usr/lib/python2.5/site-packages/trac/web/api.py", line 337, in redirect
    self.end_headers()
  File "/usr/lib/python2.5/site-packages/trac/web/api.py", line 279, in end_headers
    self._write = self._start_response(self._status, self._outheaders)
  File "/usr/lib/python2.5/site-packages/trac/web/_fcgi.py", line 1247, in start_response
    assert type(val) is str, 'Header values must be strings'
AssertionError: Header values must be strings

Attachments (0)

Change History (1)

comment:1 Changed 7 years ago by anonymous

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #1037. I've put comments into that ticket.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from coderanger. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.