Modify

Opened 7 years ago

Closed 7 years ago

#1806 closed defect (duplicate)

'MediaWikiRenderer' object has no attribute 'render_macro'

Reported by: hornsby.3@… Owned by: permon
Priority: normal Component: MediaWikiPluginMacro
Severity: blocker Keywords:
Cc: Trac Release: 0.10

Description

After adding the demo code to a page, python can't find something it needs

Python Traceback

Traceback (most recent call last):
  File "/var/lib/python-support/python2.4/trac/web/main.py", line 387, in dispatch_request
    dispatcher.dispatch(req)
  File "/var/lib/python-support/python2.4/trac/web/main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "/var/lib/python-support/python2.4/trac/wiki/web_ui.py", line 135, in process_request
    self._render_view(req, db, page)
  File "/var/lib/python-support/python2.4/trac/wiki/web_ui.py", line 443, in _render_view
    req.hdf['wiki'] = {
  File "/var/lib/python-support/python2.4/trac/wiki/formatter.py", line 999, in wiki_to_html
    Formatter(env, req, absurls, db).format(wikitext, out, escape_newlines)
  File "/var/lib/python-support/python2.4/trac/wiki/formatter.py", line 793, in format
    self.handle_code_block(line)
  File "/var/lib/python-support/python2.4/trac/wiki/formatter.py", line 732, in handle_code_block
    self.out.write(to_unicode(self.code_processor.process(
  File "/var/lib/python-support/python2.4/trac/wiki/formatter.py", line 112, in process
    text = self.processor(req, text)
  File "/var/lib/python-support/python2.4/trac/wiki/formatter.py", line 100, in _macro_processor
    return self.macro_provider.render_macro(req, self.name, text)
AttributeError: 'MediaWikiRenderer' object has no attribute 'render_macro'

I think the plugin is installed correctly:
# easy_install http://trac-hacks.org/svn/mediawikipluginmacro

And if I comment out the mediawiki.* = enabled part of the trac.ini, trac says that it doesn't know what to do with the mediawiki directive when loading the page, which makes sense.

Is there a specific dependency that this plugin relies on?

Attachments (0)

Change History (1)

comment:1 Changed 7 years ago by anonymous

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1807.

Apologies. The trac-hacks server dumped a 500 error when submitting the ticket. Ticket #1807 should be used for this issue.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from permon. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.