Modify

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#1858 closed defect (worksforme)

Mistake in installation

Reported by: mrlicker Owned by: mgood
Priority: high Component: AccountManagerPlugin
Severity: blocker Keywords: install
Cc: Trac Release: 0.10

Description (last modified by coderanger)

Hi,
i have install accountmanager with this command:
easy_install http://trac-hacks.org/svn/accountmanagerplugin/0.10

Everything was ok. I see it in webadmin/plugins. But when i begin with checking options for this plugin, it finish with error (error is only when one of these 3 options are checked: AccountModule,LoginModule,RegistrationModule;others are without error).

Here is the error:

Traceback (most recent call last):
  File "/usr/local/lib/python2.4/site-packages/trac/web/main.py", line 406, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.4/site-packages/trac/web/main.py", line 206, in dispatch
    req.hdf = HDFWrapper(loadpaths=chrome.get_all_templates_dirs())
  File "/usr/local/lib/python2.4/site-packages/trac/web/chrome.py", line 263, in get_all_templates_dirs
    dirs += provider.get_templates_dirs()
  File "build/bdist.freebsd-6.2-RELEASE-p5-i386/egg/acct_mgr/web_ui.py", line 327, in get_templates_dirs
  File "/usr/local/lib/python2.4/site-packages/setuptools-0.6c6-py2.4.egg/pkg_resources.py", line 840, in resource_filename
    return get_provider(package_or_requirement).get_resource_filename(
  File "/usr/local/lib/python2.4/site-packages/setuptools-0.6c6-py2.4.egg/pkg_resources.py", line 1311, in get_resource_filename
    return self._extract_resource(manager, zip_path)
  File "/usr/local/lib/python2.4/site-packages/setuptools-0.6c6-py2.4.egg/pkg_resources.py", line 1317, in _extract_resource
    last = self._extract_resource(
  File "/usr/local/lib/python2.4/site-packages/setuptools-0.6c6-py2.4.egg/pkg_resources.py", line 1331, in _extract_resource
    real_path = manager.get_cache_path(
  File "/usr/local/lib/python2.4/site-packages/setuptools-0.6c6-py2.4.egg/pkg_resources.py", line 921, in get_cache_path
    self.extraction_error()
  File "/usr/local/lib/python2.4/site-packages/setuptools-0.6c6-py2.4.egg/pkg_resources.py", line 887, in extraction_error
    raise err
ExtractionError: Can't extract file(s) to egg cache

The following error occurred while trying to extract file(s) to the Python egg
cache:

  [Errno 13] Permission denied: '/nonexistent'

The Python egg cache directory is currently set to:

  /nonexistent/.python-eggs

Perhaps your account does not have write access to this directory?  You can
change the cache directory by setting the PYTHON_EGG_CACHE environment
variable to point to an accessible directory.

I have tried many options but without success.
Please, can you help me with this problem?

Attachments (0)

Change History (4)

comment:1 follow-up: Changed 7 years ago by coderanger

  • Description modified (diff)
  • Resolution set to worksforme
  • Status changed from new to closed

You need to set the PYTHON_EGG_CACHE environment variable, just like the error message says. This is explained in the TracPlugins page.

comment:2 in reply to: ↑ 1 Changed 7 years ago by mrlicker

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Ok, i use this: SetEnv PYTHON_EGG_CACHE /path/to/dir . What is this directory '/path/to/dir' pls? And when I use SetEnv, it says to me bad command.

comment:3 Changed 7 years ago by mgood

  • Resolution set to worksforme
  • Status changed from reopened to closed

The directory can be anywhere that the Apache user can write to. It just needs temp space to extract some files. Please ask on the t:MailingList for more help since this is an installation question, not a bug in this plugin.

comment:4 Changed 7 years ago by mrlicker

Thank you, now it´s ok.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.