Modify

Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#1960 closed defect (fixed)

Tags from Tickets / Milestones split into multiple tags

Reported by: jtpoll@… Owned by: athomas
Priority: normal Component: TagsPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.10

Description

I have TagsPlugin configured to automatically create tags based upon ticket components, keywords, version and milestone, like so:

trac.ini:

[tags.ticket]
fields = component,keywords,version,milestone

I was looking at my tag list and wondered why there were a number of strangely-named tags. They weren't anything I remembered entering, nor were they any of my components, or versions, etc. Upon further inspection, it turns out that individual words in a Milestone name are becoming individual unique tags.

For example, Milestone: "Migrate Address Space" becomes three tags:

  • "Migrate"
  • "Address"
  • "Space"

Perhaps this is by-design? (although, I couldn't find verbiage stating as such.)

I'm using 0.10.3.1 with a MySQL backend.

Attachments (0)

Change History (6)

comment:1 Changed 7 years ago by jtpoll@…

Just confirmed -- it's not just milestone names.

Any piece of a ticket you have automatically generated into tags get split on spaces -- I have a 'Component' with more than one word in it's name and the same thing happens.

I'm starting to think this is by-design, but will wait for a reply.

comment:2 Changed 6 years ago by martin@…

Also AuthOpenIdPlugin does not work if you want to tag by owner - http://some.openid.url is split into "http" "some.openid.url"

comment:3 Changed 6 years ago by athomas

  • Resolution set to fixed
  • Status changed from new to closed

Splitting on space is by design. Splitting on : is a bug that is fixed in trunk (but only works on Trac 0.11).

comment:4 Changed 6 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

Running trac 0.11cvn, updated to tagsplugin trunk svn, I still get http and domain.org splitted for OpenID ticket owner. Also a milestone in the form someday/maybe is split into someday and maybe. is splitting on / also intentional or could only splitting on space remain? Maybe a check to see if the field looks like an URL it is not split ?

comment:5 Changed 6 years ago by athomas

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [3032]) Use same tag splitting in ticket as everywhere else. Should fix #1960.

comment:6 Changed 6 years ago by anonymous

excellent, thanks!

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from athomas. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.