Modify

Opened 7 years ago

Closed 7 years ago

#1964 closed defect (invalid)

Plugin isn't loaded in Trac 0.11

Reported by: domluc@… Owned by: bobbysmith007
Priority: normal Component: TimingAndEstimationPlugin
Severity: blocker Keywords:
Cc: Trac Release: 0.11

Description

I tried to install TaE Plugin in Trac0.11 but doesn't work.

I had checkout of 0.11 branch of plugin, I run setup.py and I get no error.

but in Trac Plugins Admin TaE plugin doesn't appear!

Attachments (0)

Change History (8)

comment:1 Changed 7 years ago by bobbysmith007

What version of the plugin are you running? I just uploaded a new version (0.4.9), that seems to work on my machine. If you are not running the latest version I would update to that. If you are and are still having problems, try turning on logging and see what error message you get (http://trac.edgewall.org/wiki/TracLogging). If you can post the error message, I should be able to help you.

Hope this helps,

Russ

comment:2 Changed 7 years ago by domluc@…

  • Priority changed from high to normal
  • Resolution set to invalid
  • Status changed from new to closed

Thx, It's help.

The problem was transform filter of Genshi, I'm just update version of Genshi and all it works as expected.

comment:3 Changed 7 years ago by smrobinson62@…

  • Resolution invalid deleted
  • Status changed from closed to reopened

I'm having the same problem but upgrading Genshi didn't help. Here's the error:

2007-08-29 17:10:38,530 Trac[loader] ERROR: Skipping "timingandestimationplugin = timingandestimationplugin": (can't import "No module named transform")

Here's what's installed in Python 2.5 and Trac is served by Apache 2.2.4 Win32.

timingandestimationplugin-0.4.9-py2.5.egg
Genshi-0.4.5dev_r730-py2.5.egg
mod_python-3.3.1-py2.5.egg-info
psycopg2-2.0.6-py2.5.egg-info
Pygments-0.8.1-py2.5.egg
setuptools-0.6c6-py2.5.egg
svn_python-1.4.4-py2.5.egg-info
Trac-0.11dev_r5963-py2.5.egg

I started with Genshi 0.4.4 and updated to 0.4.5dev today after reading this ticket. I checked to see if there were any updates to TaE's 0.11 branch in my SVN working copy today so I know I have the most recent code.

comment:4 Changed 7 years ago by khundeen

I got the same problem. Trac site went blank after installing the plugin.

My env is the Trac trunk, Genshi trunk and Python 2.5. I think there might have something to do with python 2.5

comment:5 follow-up: Changed 7 years ago by illearth

I had the same issue here, plug-in does not show up.

From the logs:

2007-08-29 22:49:38,331 Trac[loader] ERROR: Skipping "timingandestimationplugin = timingandestimationplugin": (can't import "No module named transform")

Env:

Trac-0.11dev_r5982-py2.4.egg
Pygments-0.8.1-py2.4.egg
Genshi-0.4.4-py2.4.egg
timingandestimationplugin-0.4.9-py2.4.egg

Upgraded to latest trunk version of Genshi and everything works fine.
0.4.9 requires genshi > 0.4.4

comment:6 in reply to: ↑ 5 ; follow-up: Changed 7 years ago by smrobinson62@…

I see you are running Python 2.4. Does that seem to be the workaround along with Genshi > 0.4.4? Because using Genshi 0.4.5dev with Python 2.5, etc. didn't work.

I'm wanting to run Trac0.11 on Win32 but the Trac site says it isn't likely to work with Python 2.4. Are you running Win32?

I might just go back to what I've already got running on another server (Python 2.3, Trac0.10, etc.) because we have a lot of tickets with data from the TaE plugin in them and would like to continue to use it. I was hoping to upgrade before moving servers.

comment:7 in reply to: ↑ 6 ; follow-up: Changed 7 years ago by illearth

Replying to smrobinson62@yahoo.com:

I see you are running Python 2.4. Does that seem to be the workaround along with Genshi > 0.4.4? Because using Genshi 0.4.5dev with Python 2.5, etc. didn't work.

I'm wanting to run Trac0.11 on Win32 but the Trac site says it isn't likely to work with Python 2.4. Are you running Win32?

Yes I am running Python 2.4 on Win32 (Server 2003) and everything with Trac 0.11 works fine.

Looking at the error log the plug-in cannot be loaded because Genshi 0.4.4 does not include transform (Genshi/filters/transform.py), which is needed by the plug-in 0.4.9.

I don't know what error you are getting (post your logs) but it doesn't seem like this is an issue with Python 2.4 vs. 2.5.

comment:8 in reply to: ↑ 7 Changed 7 years ago by anonymous

  • Resolution set to invalid
  • Status changed from reopened to closed

You're right. I had built branches/stable/0.4.x before. When I read your earlier note more carefully and then built trunk instead and ended up with Genshi 0.5, it has transform.py in it. I wonder why this isn't noted in the Trac0.11 notes? I see mention of a patch in a ticket in Trac's Trac but it doesn't appear to have been applied to the Genshi0.4.4 egg or zip or somehow I got a wrong copy. Anyway, thanks.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.