Modify

Opened 7 years ago

Closed 7 years ago

Last modified 3 weeks ago

#2034 closed defect (fixed)

Invalid module name (tracdownloads.tags) during build

Reported by: anonymous Owned by: Blackhex
Priority: high Component: DownloadsPlugin
Severity: major Keywords:
Cc: Trac Release: 0.10

Description

During building of an egg of the Downloads Plugin an error is reported: "error in TracDownloads setup command: ('Invalid module name', 'tracdownloads.tags ')".

The error occurs during both manual build using command
"python setup.py bdist_egg" and easy build using "easy_install http://trac-hacks.org/svn/downloadsplugin/"

Attachments (0)

Change History (4)

comment:1 Changed 7 years ago by Blackhex

  • Status changed from new to assigned

I think that your problem is caused by version of your setuptools. I'm using 0.6rc3 and everything goes fine. There is used extras_require in DownloadsPlugin which was introduced in 0.5a4 if I read change log correctly. What is your setuptools version?

comment:2 Changed 7 years ago by anonymous

Hi,

the version of setuptools I am using is 0.6a9-1ubuntu1, which comes from the Ubuntu repository and is installed as a package through apt-get utility.

comment:3 Changed 7 years ago by anonymous

Hello again,

I removed the mentioned setuptools and installed a 0.6c7 version. After this all worked well.

Thank you for your help.

comment:4 Changed 7 years ago by Blackhex

  • Resolution set to fixed
  • Status changed from assigned to closed

OK, I'm closing this then.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from Blackhex. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.