Modify

Opened 7 years ago

Last modified 6 years ago

#2118 reopened defect

list + code block formating breaks ...

Reported by: ThurnerRupert Owned by: jun66j5
Priority: normal Component: TracWysiwygPlugin
Severity: major Keywords:
Cc: Trac Release: 0.10

Description

a formatting like the following gets broken by wysiwyg editor:

  1. first
    first block
    
  2. second
    second block
    

and there the text continues

the source is

 1. first
{{
first block
}}
 1. second
{{{
second block
}}
}}}

Attachments (0)

Change History (7)

comment:1 Changed 7 years ago by jun66j5

  • Resolution set to fixed
  • Status changed from new to closed

(In [2759])

  • added unit tests.
  • fixed #2118
  • fixed some bugs in wikitext-generation.

comment:2 Changed 7 years ago by ThurnerRupert

  • Resolution fixed deleted
  • Status changed from closed to reopened

unfortunately, the newlines are still here, which prevents auto-numbering item lists. the result should be (used two {{ instead of three):

 1. first
{{
first block
}}
 1. second
{{
second block
}}

but it is

 1. first

{{
first block
}}
 1. second

{{
second block
}}

which makes the numbering start at one at every item.

comment:3 Changed 7 years ago by jun66j5

It works for me.
Please try clearing the browser cache or forcing reload (shift+reload).

comment:4 follow-up: Changed 7 years ago by JasonWinnebeck

When I test this by pasting in his example text, it displays and round-trips properly. However, if you try to construct his example in the editor itself it blows up very strongly.

What I did is this:

  1. Press numbered list
  2. Type "first" + <enter>
  3. Select "code block" (note I got a bug here where the code block started with a * in it)
  4. Type "first block" + <enter>
  5. Select "normal" style
  6. Press numbered list button
  7. Type "second block" + <enter>
  8. Press numbered list button
  9. Select "code block" style

I got the really messed up text immediately in the editor (in wiki format):

{{
 1. First

{{
 First block
}}
 1. Second Block
}}
 1. First

{{
 First block
}}
 1. Second Block

comment:5 Changed 7 years ago by ThurnerRupert

  • Resolution set to fixed
  • Status changed from reopened to closed

cannot reproduce the original thing, maybe it really was in our company proxy. sorry for bothering.

just small weirdnesses stay, trying to continue at the end of the list:

  • indent code block in this numbered list does not work
  • try to continue writing in "normal" after the last code block
    • continued in next line
    • marked the line as "normal"
    • then above the code block the empty line was there again

comment:6 Changed 7 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

ui ... should i reopen it?

comment:7 in reply to: ↑ 4 Changed 6 years ago by JasonWinnebeck

Replying to JasonWinnebeck:

I tried to test this again and it does behave differently (perhaps not correct but a lot better than when I last saw it), but I can't verify the wikitext generated because my browser freezes due to #3611. I'm not sure what causes #3611 except that apparently it happens on more things than just bullet lists.

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.