Modify

Opened 7 years ago

Last modified 7 years ago

#2120 reopened enhancement

display all mercurial repositories in a subfolder

Reported by: anonymous Owned by: djc
Priority: normal Component: HgTimelinePlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

does display of all hg repositories in one folder work with

hg.parentdir=/....

and does it allow to read the .hgrc file, and get the url out of it?

Attachments (0)

Change History (3)

comment:1 Changed 7 years ago by djc

  • Resolution set to invalid
  • Status changed from new to closed

You have to list all hg repositories explicitly, there is not parentdir thing.

Also, it doesn't read .hgrc; I think it doesn't usually contain any URL's?

Anyway, as this is not a bug or enhancement, closing it as invalid. For further questions, you should probably catch me in IRC (djc in #trac at irc.freenode.net) or email me (manuzhai@…).

comment:2 Changed 7 years ago by ThurnerRupert

  • Resolution invalid deleted
  • Status changed from closed to reopened

sorry, wanted to say: read the collections out of hgweb.config, like the mercurial web gui does ...

the goal would have been to just specify two parameters:

  1. the url
  2. the directory where the config file is found

then it could use the same logic as mercurial weg gui to find the contained repositories.

comment:3 Changed 7 years ago by djc

  • Trac Release changed from 0.10 to 0.11

Actually, using the hgwebdir config would be kind of nice, since it would be configured anyway to get the kind of behavior you need for the linking. Hmmm...

Add Comment

Modify Ticket

Action
as reopened The owner will remain djc.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.